Make Older Add-Ons Work with Firefox 3.0

If you're like me, you've been playing around with the beta releases of Firefox 3.0. The new version of the open source browser is better-looking, uses less memory, and feels snappier all around. There's just one problem: Every time they release a new beta version, some of your extensions and add-ons are bound to stop working. With the release of Firefox 3.0rc1, almost none of them work.

Fortunately, there is a solution that will "fix" all of your extensions at once. But I caution you, it's not for the weak-hearted. The fix doesn't take longer than a few seconds, but when it comes to troubleshooting your browser afterward, you'll be on your own.

I can't repeat this enough. DO NOT TRY THIS unless you are comfortable editing the advanced preferences of your browser. And don't do anything until you've read through this entire post. Don't say I didn't warn you.

In my experience, extensions that worked with Firefox 3.0b5 will generally be stable with 3.0rc1. It is possible, however, that some of them will cause the new version of the browser to crash. It might even crash on startup -- which means, obviously, that you won't easily be able to undo the fix I'm about to describe.

The key to the fix is to prevent Firefox from checking its version number before it tries to load extensions. To do this, you will need to set a new preference value. Point your browser at the URL "about:config", then right-click on the preferences list to bring up the contextual menu. You should see an option that says "New." Select that, and choose "Boolean." When it asks you for the preference name, type "extensions.checkCompatibility" (without the quotes). You have to enter the name exactly. For the value, choose "false."

Now restart Firefox. When the browser comes back up, it should give you a warning that version checking is disabled. You can double-check under "Tools:Add-Ons" to make sure everything is activated once again.

If the worst case happens and the browser won't start after you add the new preference, you'll need to remove it by hand. Locate the file "prefs.js" within your Firefox profile directory and edit it with any text file editor to delete the line with the preference you just created. (If you're not comfortable doing that, then as I've said, this fix is probably not for you.)

Also, you'll want to remember to delete the preference once the final version of Firefox 3.0 is released, or else you'll never be certain that your installation is stable.

Good luck. As I've said before, I can't troubleshoot any individual Firefox installations. But hopefully this will help you keep your most-beloved add-ons running until their maintainers update them for the final Firefox 3.0. If you still have trouble with some extensions under Firefox 3.0rc1, you can post your experience here in the PC World Community Forums.

To comment on this article and other PCWorld content, visit our Facebook page or our Twitter feed.
Shop Tech Products at Amazon