Security

Bugs and Fixes: Microsoft Patches 34 Vulnerabilities

Source: Apple

This month Microsoft patched thirty-four vulnerabilities, several of which are highly dangerous and have an exploitability vulnerability of 1. Apple released updates for Mac OS X patching a number of vulnerabilities which could allow an attacker to gain personal or secure information. Finally, Adobe released an unusual number of patches this month which fix a number of vulnerabilities across a multitude of Adobe products including ColdFusion and LiveCycle.

Microsoft Patch Tuesday

Source: Microsoft
In this month's Tuesday Patch Microsoft released 16 security bulletins addressing vulnerabilities in everything from Windows and the .NET Framework to Internet Explorer. Nine of the Patch Tuesday updates are rated critical and the rest are rated important.

While Microsoft recommends that you install all updates, they suggest that if you must prioritize or manually download them that you download four critical updates first which Microsoft named as priority one issues.

Update MS11-050, rated critical, affects Internet Explorer and is one of the priority one issues. It also has an exloitability vulnerability rating of 1--in other words, it's the most in danger of being exploted. This update alone resolves eleven vulnerabilities, the most severe of which could allow an attacker to execute remote code execution if you viewed an exploted webpage on Internet Explorer.

Another critical update with an exploitability vulnerability rating of 1 is MS11-052 which resolves two vulnerabilities in Distributed File Servers (DFS)--a Microsoft service that allows files to be stored on a network. These vulnerabilities could allow remote code execution if an attacker successfully exploited them.

As usual, you should install these as soon as possible using Windows Update. To learn more about each update--and to download them manually--visit Microsoft's Safety and Security Center.

Apple Updates Mac OS X

This month Apple released a number of updates for Mac OS X v10.5.8 and Mac OS X v10.6 - v10.6.7. The disclosed vulnerabilities could allow an attacker to execute code on the system, for applications to unexpectedly terminate, applications to receive denial of service, and more.

Apple updated the Certificate Trust policy for Mac OS X v10.6 - v10.6.7 and Mac OS X Server v10.6 - v10.6.7. The disclosed vulnerability could allow an attacker to intercept user credentials or other sensitive information because of a handling error--a validation protocol.

Apple also updated the Mac OS X server FTP system due to an error that allows someone with FTP access to list files on the system including files that are not shared. Although the contents of the files are not disclosed this could constitute a security problem.

MobileMe, Apple's subscription-based online services and software, was updated to fix a vulnerability which allowed an attacker with a "privileged network position" to view a person's email aliases because MobileMe was operating over unsecure HTTP. Apple fixed the issue by using SSL or a Secure Sockets Layer--a security protocol.

As the usual, you should install these as soon as possible. To learn more about each update--and to download them manually--visit Apple Support.

Multiple Adobe Patches

Adobe released six security updates this month to patch vulnerabilities in Adobe Flash Player, ColdFusion, LiveCycle, BlazeDS, Reader, Acrobat, and Shockwave Player (If you don't know what some of those are then it probably doesn't affect you).

This month Adobe released two updates for Adobe Flash Player, one rated important and the other rated critical. According to Adobe, CVE-2011-2107 addresses vulnerabilities in "Flash Player 10.3.181.16 and earlier versions for Windows, Macintosh, Linux and Solaris, and Adobe Flash Player 10.3.185.22 and earlier versions for Android" and is rated important. If you visited a malicious site an attacker could, on your behalf, take actions on a website or a webmail provider--essentially hacking you.

Similar vulnerabilities (rated important) to CVE-2011-2107 were also found in ColdFusion 9.0.1-- rapid application development platform--and earlier versions for Windows, Macintosh and UNIX. These vulnerabilities allow a user to forge your identity.

In Adobe Reader 10.0.1 and earlier (Windows), Adobe Reader 10.0.3 and earlier (Mac), and Adobe Acrobat 10.0.3 and earlier (Windows and Mac), critical vulnerabilities were found which could cause an application to crash and allow an attacker to take control of your system. Additionally, Adobe patched vulnerabilities in Adobe Shockwave Player 11.5.9.620 and earlier (Windows and Mac) which could let an attacker run malicious code on your system.

As usual, you should install these as soon as possible. To learn more about each update--and to download them manually--visit Security bulletins and advisories.

Follow James Mulroy on Twitter and on Stumble Upon to get the latest in microbe, dinosaur, and death ray news.

Subscribe to the Security Watch Newsletter

Comments