Security

Samba Security Patch Fixes Critical Remote Code Execution Hole

The developers of Samba, the open source software that enables file and print sharing between Linux, Windows and Mac OS X computers, released security patches on Tuesday to address a critical vulnerability that can be exploited by remote attackers to execute arbitrary code on systems where the Samba service is running.

The vulnerability is identified as CVE-2012-1182 and is located in Samba's code that handles the processing of remote procedure call (RPC) requests, particularly their translation into a Network Data Representation (NDR) format.

A client can send a specially crafted RPC call to a Samba server in order to exploit the vulnerability and execute unauthorized code with administrative privileges (root) on the system.

"As this does not require an authenticated connection it is the most serious vulnerability possible in a program, and users and vendors are encouraged to patch their Samba installations immediately," the Samba development team said in a security advisory.

In order to mitigate the risks associated with this vulnerability, Samba administrators can either upgrade their installations to the newly released Samba 3.6.4, Samba 3.5.14 and 3.4.16 versions, depending on which branch they use, or manually apply patches to their installations without upgrading.

The vulnerability is very serious and this is also evident from the Samba development team's decision to release patches even for versions that are no longer officially supported, said Carsten Eiram, chief security specialist at vulnerability management firm Secunia.

Secunia rated the vulnerability as moderately critical because best use practices dictate that Samba services should only be accessible over local area networks. However, Samba can also be configured to work over the Internet and for cases like that, the vulnerability should be considered highly critical, Eiram said.

Samba comes installed by default on most Linux distributions, as well as on Apple's Mac OS X Server. It is also available for BSD, Solaris and other UNIX-like operating systems.

In addition to being commonly installed on many computers, Samba is also used in many UNIX-based devices like network printers or network storage devices, Eiram said.

This makes this vulnerability an attractive target for exploit writers, both for integration in commercial and free penetration testing tools like Metasploit, as well as for use in malicious attacks. "An unauthenticated code execution vulnerability in Samba is very interesting to create a working exploit for," Eiram said.

Subscribe to the Security Watch Newsletter

Comments