










<!DOCTYPE html>


	
	
	
		
		
	
	
	
	

<html lang="en">
	












<head>
	<link rel="alternate" hreflang="en" href="https://www.pcworld.com/article/3336148/bloody-b975-gaming-keyboard-review.html" />	
	<meta charset="utf-8" />
	<title>Bloody B975 review: The optical switches impress even if the 'edgy' aesthetic doesn't | PCWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js"></script>
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/vfk2oJkpFG3vht2YK9N27PTefzTe3eLddsxvafcpjop9vedvRUWqqRmxuxgdcJYUfd9",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>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</script>



	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "pcw";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "";
var linkedInUrl = "";
var facebookUrl = "";
if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
if (countryCode === 'asean') {
	busUnit = "";
}
if (countryCode === 'uk') {
	busUnit = "";
}
</script>

	

	
    <script src="/www/js/init_device.js"></script>    
    
    
    
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20190321115630"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_PCWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "hardware_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/hardware');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'hardware');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1441120');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1442383');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1442383');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("productId", '1442383');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3336148');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'reviews');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '3');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'amazon');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-review');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3020,3131]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['hardware','input-keyboards']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [329,366]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Hayden Dingman');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20190321115630"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	

	

    <link rel="canonical" href="https://www.pcworld.com/article/3336148/bloody-b975-gaming-keyboard-review.html" />
	
	
	
	
	
	<meta name="description" content="Bloody&#039;s B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch." />
	
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/02/bloody_b975_2-100787241-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2019-03-22" />
			<meta name="date" content="2019-03-22" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.pcworld.com/article/3336148/bloody-b975-gaming-keyboard-review.amp.html" />

	
		<script type="text/javascript" src="//fonts.staticworld.net/ehr0jod.js"></script>
		<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
	
	
	<meta property="twitter:account_id" content="6070762" />
	<meta property="fb:app_id" content="1542125639335283" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.pcworld.com/article/3336148/bloody-b975-gaming-keyboard-review.html">
    <meta property="og:site_name" content="PCWorld">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2019/02/bloody_b975_2-100787241-large.3x2.jpg">
    	<meta property="og:image:width" content="700">
    	<meta property="og:image:height" content="467">
    
    
    
    
    
    
    	<meta property="og:title" content="Bloody B975 review: The optical switches impress even if the 'edgy' aesthetic doesn't"> 
    
    
    <meta property="og:description" content="Bloody&#039;s B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch.">
    
    
		<meta property="fb:pages" content="7352931005" />
	

	
	<meta name="displaytype" content="article" />
	
	<meta name="associatedproducts" content="razer huntsman elite,bloody b975" />
	
	<meta name="source" content="pcworld" />
	
	<meta name="category" content="hardware,keyboards" />
	
	<meta name="storytype" content="reviews" />
	
	
	
		<meta name="google-site-verification" content="FjWdymWSdutZJ-XIYfqJXlQZbLR7hMWmkwR5MQ0yqeY" />
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20190321115630" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20190321115630" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.pcw/css/inline-header.css?v=20190321115630" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20190321115630" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-layout.css?v=20190321115630" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20190321115630" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-colors.css?v=20190321115630" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20190321115630" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-typography.css?v=20190321115630" rel="stylesheet" />
	
	
	
	
		
		
			
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20190321115630" />	
			
			
		<link href="/www.idgcsmb.pcw/css/article.css?v=20190321115630" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20190321115630" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
		<script>
		try {
			performance.mark("mark_head_css_done_blocking");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.pcw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Hayden Dingman";
			
		
			
			
	_sf_async_config.sections="hardware";	
		
		
		
		
	_sf_async_config.domain = "pcworld.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Bloody&#039;s B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch.">
	
	
		
			<meta name="twitter:site" content="@pcworld">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/02/bloody_b975_2-100787241-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="Bloody B975 review: The optical switches impress even if the &#039;edgy&#039; aesthetic doesn&#039;t">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.pcworld.com">
				
			
		
		
		
		
		
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.pcworld.com/",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.pcworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	<script>
	var supMontMods = false;
	</script>
	


	
	
			
			
				
					
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		
















	


			
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	 
	 
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	 
	 
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
		
		<script>
			prodNames += "Bloody B975" + "|";
			prodManufacturers += "BLOODY" + "|";
			prodCategories += "Hardware" + "|";
			prodVendors += "Amazon" + "|";
		</script>
		
	
	
	<script>
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined') {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode;
	}

	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	dataLayer=[{
		'articleId': '3336148',
		'articleDisplayId':'1',
		'articleLocale': '',
		'articleTitle': 'Bloody B975 review: The optical switches impress even if the \'edgy\' aesthetic doesn\'t',
		'articleType': 'Reviews',
		'audience':'consumer',
		'author':'Hayden Dingman',
		'blogName':'',
		'brandpost': '',
		'categoryIdList':'3020,3131',
		'categoryIdPrimary': '3020',
		'contentStrategy': '',
		'contentType':'reviews',
		'datePublished':'2019-03-22',
		'dateUpdated':'2019-03-22',
		'daysSincePublished':'0',
		'daysSinceUpdated':'0',
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-739745-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '329',
		'goldenTaxonomyIdList': '366',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'hardware',
		'ancestorGoldenCategories': '',
		'primaryCategoryList': 'keyboards',
		'primaryAncestorCategoryList': '',
		'property': 'pcworld',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'skimlinksId':'111346X1569483',
		'source':'pcworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false',
		'prodNames':prodNames.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodCategories':prodCategories.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1)	
	}];
	</script>
	 
	
	
	
		













		
			<!-- Page hiding snippet (recommended)  -->
			<style>.async-hide { opacity: 0 !important} </style>
			<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
			h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
			(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
			})(window,document.documentElement,'async-hide','dataLayer',4000,
			{'GTM-KVP87FZ':true});</script>
			<!-- Modified Analytics tracking code with Optimize plugin -->
			    <script>
			    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			
			 // We need to create the UA tracker here in order to link it to Optimize - even though everything else is in GTM
			  ga('create', 'UA-739745-1', 'auto', {'useAmpClientId': true});  
			  ga('require', 'GTM-KVP87FZ');           
			  
			</script>

	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
		<script>
			try {
				performance.mark("mark_head_js_done_blocking");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");

			}
		</script>
	
	
	
	
		<script>
			function bindPerformanceMarks(){
			//even though it's called slotRenderEnded, it's the first thing to happen -  corresponds to when we get a response back from DFP
			googletag.pubads().addEventListener('slotRenderEnded', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial' && !event.isEmpty) {//also ensure it's not an empty ad response
					performance.mark("mark_welcome_render_begin");
				}
			});
			googletag.pubads().addEventListener('slotOnload', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_render_end");
				}
			});
			googletag.pubads().addEventListener('impressionViewable', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_impression_viewable");
									
				}
			});
				}
				try {
					IDG.GPT.googleCommandPush(bindPerformanceMarks);
				}
				catch(e){
					console.log('error binding performance marks: ' + e);
				}
		</script>
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/183980-214854100715128.js"></script>
	
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	
	
	
	
	
	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'Bloody\'s B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'Bloody\'s B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-03-22T09:10:20Z",
	        publishedAt: "2019-03-22T09:10:20Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [329,],
	        secondaryIds: [366,]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  window.permutive.track('User', {
			  companySize: null,
			  country: null,
			  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
			  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
			  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
			  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
			})
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
</head>

	<body id="article3336148" class="article review pcworld">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			
		  		<script type="text/javascript">
		  		
		  		
				document.write('<div id="gpt-superstitial" class=" ad-container"></div>');
				consent.ads.queue.push(function(){
			  		try {			  			
			   			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
			   			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
			   			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
			   		}
					catch (exception) {
						console.log("Error with IDG.GPT: " + exception);
					}
		  		});
				
				</script>
		
		
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		











	
	
		
		
		
		
		
			
		
				
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


		
		
		
		
		
		
		
		
		
		
		
		<div id="page-top">
				<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
				<link itemprop="url" href="http://www.pcworld.com"> 
			    
		
		
		
		
		<div class="network-header">
				<div class="network-header-inner">
					<div id="network-tools">
		
						<div id="saved-comparisons"></div>				
						<ul class="hmenu" id="heroLogin">				
							<li class="subscribeHeader"><a href="/magazines">Subscribe</a><div class="subscribe-hover" style="">
		                        <div class="pointer">&#9650;</div>
		                        <span>Learn more about PCWorld's Digital Editions</span>
		                        <img alt="PCWorld Magazine Cover" src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png">
		                      </div></li>
							
						</ul>
					</div><!-- /#network-tools -->
		
						<div id="network-social">					
		                  
							
							<a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
								&#xF610;
							</a>
							<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
								&#xF611;
							</a>
							<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
								&#xF630;
							</a>
		
						<form id="search-form" action="/search">
							<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
							<input type="submit" name="submit" id="banner-search-submit" value="search" />
							<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
						</form>
		
						</div><!-- /#network-social -->
					
						
				</div>
			</div><!-- /.network-header -->
		
		
			<header id="banner">
				<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
				<div id="logo">
					<a href="/" class="ir banner-logo" id="logoImage">Home</a>		
				</div>
				<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
			</header>
		
		
			



















<div id="main-nav">
	<div class="container clearfix">
		<ul class="fmenu" id="panel-nav">
			<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
			
			
				<li class="dealsNav"><a href="/deals" id="dealsNav">Deals <span class="ss-dropdown right"></span></a> 
					<ul class="dealsList">
						<li><a href="/deals" id="dealsNav">Deals</a></li>
						<li><a href="https://www.pcworld.com/couponcodes">Coupon Codes</a></li>
						<li><a href="https://shop.pcworld.com">Shop</a></li>
					</ul>
				</li>
			

		</ul>

		<ul class="fmenu" id="site-nav">
			
				<li><a href="/category/business/">Business</a>
					
				</li>
			
				<li><a href="/category/laptop-computers/">Laptops</a>
					
				</li>
			
				<li><a href="/category/smartphones/">Smartphones</a>
					
				</li>
			
				<li class="selected"><a href="/category/hardware/" class="active">Hardware</a>
				
					<ul>
						
								
									
									
										<li><a href="/category/computers/">PCs</a></li>
									
													
						
								
									
									
										<li><a href="/category/components-graphics/">Graphics Cards</a></li>
									
													
						
								
									
									
										<li><a href="/category/input-devices/">Input Devices</a></li>
									
													
						
								
									
									
										<li><a href="/category/displays/">Displays</a></li>
									
													
						
								
									
									
										<li><a href="/category/printers/">Printers</a></li>
									
													
						
								
									
									
										<li><a href="/category/storage/">Storage</a></li>
									
													
						
								
									
									
										<li><a href="/category/networking/">Networking</a></li>
									
													
						
								
									
									
										<li><a href="/category/cameras/">Cameras</a></li>
									
													
						
					</ul>
					
				</li>
			
				<li><a href="/category/security/">Security</a>
					
				</li>
			
				<li><a href="/category/software/">Software</a>
					
				</li>
			
				<li><a href="/category/gadgets/">Gadgets</a>
					
				</li>
			
			<li class="displayMobileOnly"><a href="/magazines">Subscribe</a></li>
			
		</ul>
		
			<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
			
			<div id="extra-nav">
				<ul>
					
						<li><a href="/resources/">Resources</a></li>
					
						<li><a href="/category/computers/">PCs</a></li>
					
						<li><a href="/category/smartphones/">Smartphones</a></li>
					
						<li><a href="/category/printers/">Printers</a></li>
					
						<li><a href="/category/ultrabooks/">Ultrabooks</a></li>
					
					<li><a href="/blogs">Blogs</a></li>
				</ul>
				<ul>
					
						<li><a href="/category/antivirus-software/">Viruses</a></li>
					
						<li><a href="/category/cameras/">Cameras</a></li>
					
						<li><a href="/category/components/">Components</a></li>
					
						<li><a href="/category/computers-accessories/">Computer Accessories</a></li>
					
						<li><a href="/category/consumer-advice/">Consumer Advice</a></li>
					
						<li><a href="/category/digital-assistants/">Digital Assistants</a></li>
					
						<li><a href="/category/displays/">Displays</a></li>
					
						<li><a href="/category/e-readers/">E-readers</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/components-graphics/">Graphics Cards</a></li>
					
						<li><a href="/category/storage-drives/">Hard Drives</a></li>
					
						<li><a href="/category/home-theater/">Home Theater</a></li>
					
						<li><a href="/category/input-devices/">Input Devices</a></li>
					
						<li><a href="/category/input-keyboards/">Keyboards</a></li>
					
						<li><a href="/category/laptop-accessories/">Laptop Accessories</a></li>
					
						<li><a href="/category/mobile/">Mobile</a></li>
					
						<li><a href="/category/networking/">Networking</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/operating-systems/">Operating Systems</a></li>
					
						<li><a href="/category/storage-optical/">Optical Drives</a></li>
					
						<li><a href="/category/cpu-processors/">CPUs</a></li>
					
						<li><a href="/category/servers/">Servers</a></li>
					
						<li><a href="/category/smartwatches/">Smartwatches</a></li>
					
						<li><a href="/category/streaming-services/">Streaming Services</a></li>
					
						<li><a href="/category/storage/">Storage</a></li>
					
						<li><a href="/category/tablets/">Tablets</a></li>
					
						<li><a href="/category/windows/">Windows</a></li>
					
				</ul>
			</div>
		
	</div>
</div>	<!--/#main-nav-->


<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/computers/">PCs</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/components-graphics/">Graphics Cards</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/input-devices/">Input Devices</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/displays/">Displays</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/printers/">Printers</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/storage/">Storage</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/networking/">Networking</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/cameras/">Cameras</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->








		
		
				</div> 
			</div> 
		
		
		
		
					<!-- Events Header -->
				
					
						
						 
							
								
								
								
								
								
											    			
								
							
							
							
							
							
						
						 
						 
						 
						 
						  
						  
						 
						 
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


				
		
		
		<script>
		$(document).ready(function(){
			$('.searchbox-input-class').each(function(){
			    $(this).change(function(){
			    	var qStr=$(this).val();
			    	if($(this).val().indexOf('@')!=-1){
			    		qStr=qStr.replace(/@/g,' ');
			    		$(this).val(qStr);
			    	}
			    });
			});
		});
		</script>
	


		
		











<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">

		<article itemscope itemtype="http://schema.org/Review"  >

		











	
	























	
	
		<script>
		$(document).ready(function() {
			var fullDate = "March 22, 2019 09:06 AM";
			document.querySelector(".format-date").textContent = fullDate;
		});
		</script>
	




	
			















<header class='cat'>

	
	
	
	
	
	
	
	
	
		<!-- CSMB Horizontal Responsive -->
<ins class="adsbygoogle"
     style="display:block;"
     data-ad-client="ca-pub-4268075595326305"
     data-ad-slot="9945794902"
     data-ad-format="link"></ins>


<script>
consent.ads.queue.push(function(){
	$.getScript( "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" )
		  .done(function( script, textStatus ) {
		    //need to add  && publisherConsents.gdprApplies back to the end of this conditional after testing
			  if (!consent.personalization && consent.isEU)  {
				   (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1
				   console.log('*****GDPR: loaded adsense in non-personalized mode')
			  }
			  else {
			   		(adsbygoogle = window.adsbygoogle || []).push({});
			   	 	console.log('*****GDPR: loaded adsense in normal mode');
			  } 
		  })
		  .fail(function( jqxhr, settings, exception ) {
		    console.log( "Triggered ajaxError handler." );
		});
});
</script>
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a class="edition-link-url" href="/category/hardware/" itemprop="url"><span class="article-primary-cat" itemprop="title">Hardware</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><a class="edition-link-url" href="/reviews" itemprop="genre">Review</a></div>
		
	
	

	<h1 itemprop="headline">Bloody B975 review: The optical switches impress even if the 'edgy' aesthetic doesn't</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">It's blood-resistant as well.</h3>
		</section>
	
	
	
	
			<div class="cat-social">
				
					
				


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&via=pcworld&text=Bloody+B975+review%3A+The+optical+switches+impress+even+if+the+%27edgy%27+aesthetic" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&description=Bloody+B975+review%3A+The+optical+switches+impress+even+if+the+%27edgy%27+aesthetic" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&title=Bloody+B975+review%3A+The+optical+switches+impress+even+if+the+%27edgy%27+aesthetic" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3336148">
		<input type="hidden" name="title" value="Bloody B975 review: The optical switches impress even if the \'edgy\' aesthetic doesn\'t" />
		<input type="hidden" name="url" value="https://www.pcworld.com/article/3336148/bloody-b975-gaming-keyboard-review.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on PCWorld." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Hayden-Dingman/" rel="author" title="Hayden Dingman"><img  class="bylineImage  imgId100035890 " src="https://images.techhive.com/images/article/2013/05/hayden_dingman_2-100035890-byline.jpg" width="34" width="34" alt="Hayden Dingman" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Hayden-Dingman/"><span itemprop="name">Hayden Dingman</span></a></span>
						</p>
						<p class="dateline">
						
							Games Reporter, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">PCWorld</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2019-03-22T09:06-0700"><span class="format-date"></span>
								<span class="time-zone"> PT</span>
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	
	
	
	
		<div class="lede-container">
			
			
			
				
				
					
		                
		                	
		                	
		                
		                
						
						
						
					
					
					
					
					<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
						<meta itemprop="representativeOfPage" content="1" />
						<meta itemprop="height" content="331" />
						<meta itemprop="width" content="700" />
			    		
			    		<img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_2-100787241-large.jpg" alt="Bloody B975" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
			    		
				    		<script>
				    			try {
				    				performance.clearMarks("mark_primary_img_rendered");
									performance.mark("mark_primary_img_rendered");
				    			}
				    			catch(e) {
				    				console.log("Error saving performance mark -- this function may not be supported in this browser");
				    			}
							</script>
						
			    		<figcaption>
			    			
			    			
			    				<span class="credit" itemprop="copyrightHolder">
			    					
					    				
					    				IDG / Hayden Dingman
				    				
		
					    			
					    				
					    				
					    				
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
					    				
					    				
										
									
							
								</span>
			    			
							
			    		</figcaption>
					</figure>
					
		
				
				
			
		</div>
	











	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
	
		











<!-- Related -->


 
	
	
	
		
		
				
   	
   	
   	
   		
   			
   		











<!-- Related -->









 <!-- Temporarily turn off "More like this" module and replace with ZipRecruiter -->


	<div class="related-promo-wrapper">
		<div class="sector apart">
			<div class="hed">More like this</div>
	    	<ul class="">
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3185872/best-gaming-keyboard.html"><img  class="small.3x2Image  imgId100734536 " src="https://images.idgesg.net/images/article/2017/09/gaming-keyboard-hub-hero-crop-100734536-small.3x2.jpg" alt="gaming keyboard hub hero crop" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3185872/best-gaming-keyboard.html">Best gaming keyboards: Our picks for the top budget, mid-tier, and RGB boards</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3317698/roccat-vulcan-120-aimo-keyboard-review.html"><img  class="small.3x2Image  imgId100778536 " src="https://images.idgesg.net/images/article/2018/10/roccat_vulcan_120_aimo_1-100778536-small.3x2.jpg" alt="Roccat Vulcan 120 Aimo" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3317698/roccat-vulcan-120-aimo-keyboard-review.html">Roccat Vulcan 120 Aimo review: Cherry-style RGB switches done right</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3287970/razer-huntsman-elite-keyboard-review.html"><img  class="small.3x2Image  imgId100764491 " src="https://images.idgesg.net/images/article/2018/07/img_20180706_202831-100764491-small.3x2.jpg" alt="Razer Huntsman" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3287970/razer-huntsman-elite-keyboard-review.html">Razer Huntsman Elite review: Optical switches arrive, but that&#039;s not even the...</a></div>
	</div>
</li>
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
							
						
					














<li class="clearfix with-image">
	
		<a  class="play" href="/video/94467/oculus-rift-s-hands-on"><i class="ss-play"></i></a>
		<a  href="/video/94467/oculus-rift-s-hands-on"><img  class="small.3x2Image  imgId100791406 " src="https://images.idgesg.net/images/article/2019/03/pho19_093_oculusrifts-100791406-small.3x2.jpg" alt="Oculus Rift S" itemprop="image" /></a>
    
	<div class="item">
		<div class="item-eyebrow">Video</div>
		<div class="title"><a  href="/video/94467/oculus-rift-s-hands-on">Oculus Rift S hands-on</a></div>
	</div>
</li>
				
				
			
		
	




					
				
		    </ul>
		</div>
	</div>



   	


				<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	
</section>









	





















	
	
	






	
	
	
	
	
	
	
	<div class="at-a-glance single top" data-tracking-category="ecomm-aag-top">
		
		<div class="product-list-header">At a Glance</div>
		<ul class="aag-list">
			
			
				
						
							
						
						
				
				
				<li class="aag-item single " data-product-id="1442383" >
					
						<div class="product-left">
						
						<span itemscope itemtype="http://schema.org/Product" itemprop="itemReviewed">
					
					
						
						
					
					<h3 class="product-name" itemprop="name">
						
							
							Bloody B975
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span class="rating-star four-star"></span><meta itemprop="ratingValue" content="4.0"></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-001-1442383-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1442383" data-po="amazon" data-bkc="Hardware" data-bkmfr="BLOODY" data-bkvndr="Amazon" data-product-name="Bloody B975" data-vars-product-id="1442383" data-vars-bkmfr="BLOODY" data-vars-bkvndr="Amazon" data-vars-product-name="Bloody B975" data-vars-outbound-link="https://www.amazon.com/Strike-Optical-Gaming-Keyboard-Smooth/dp/B079HJCZ45?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=pcworld02-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B079HJCZ45" data-vars-link-position-id="001" data-vars-link-position="AAG Top">$149.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-001-1442383-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1442383" data-po="amazon" data-bkc="Hardware" data-bkmfr="BLOODY" data-bkvndr="Amazon" data-product-name="Bloody B975"  data-vars-product-id="1442383" data-vars-bkmfr="BLOODY" data-vars-bkvndr="Amazon" data-vars-product-name="Bloody B975" data-vars-outbound-link="https://www.amazon.com/Strike-Optical-Gaming-Keyboard-Smooth/dp/B079HJCZ45?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=pcworld02-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B079HJCZ45" data-vars-link-position-id="001" data-vars-link-position="AAG Top">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-001-1442383-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				
			</li>
			
		</ul>
	</div>









		<section class="bodee">

			
				
				
					



















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	







	<div class="ad placement">
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="inread" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("inread", "true");
					IDG.GPT.displayGoogleTagSlot('inread');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
	</div>








	
	
		
		
		<script>
			var dataLayer = window.dataLayer = window.dataLayer || [];
			dataLayer.push({
				'event': 'loadTopCollectionModule'
				});
		</script>
		
	


















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		

	

		












	
	



<script type="text/javascript">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</script>






	
		
	
	





	
		
			
			
			
				
			
			
		
	
	


	
	
		<div id="drr-container" class='cat ' itemprop="reviewBody">
	
	
	
	

	<p>Optical keyboards entered the mainstream last year with <a href="https://www.pcworld.com/article/3287970/hardware/razer-huntsman-elite-keyboard-review.html"> Razer’s Huntsman Elite</a>. But as I noted at the time, Razer was far from the first company to explore optical keyboard switches. A few years back I started noticing a company called “Bloody” showing up at every trade show, fronting huge booths full of keyboards—ones equipped with optical switches.</p><p>Why it’s taken us so long to review one of Bloody’s keyboards, I’m not sure, but we’ve finally gotten our hands on one. Bloody recently sent us its B975, one of its more recent (and more refined) models. I’ve spent the last few weeks typing on it, and you know what? I like it—even if Bloody’s claims about optical switches are a bit overblown.</p><p><em><span class="TextRun SCXW139123568" lang="EN-US" xml:lang="EN-US"><span class="NormalTextRun SCXW139123568">Note: This review is part of our </span></span><a href="https://www.pcworld.com/article/3185872/best-gaming-keyboard" rel="noopener" target="_blank"><span class="TextRun Underlined SCXW139123568" lang="EN-US" xml:lang="EN-US"><span class="NormalTextRun SCXW139123568">best gaming keyboards </span></span></a><span class="TextRun SCXW139123568" lang="EN-US" xml:lang="EN-US"><span class="NormalTextRun SCXW139123568">roundup. Go there for details about competing products and how we tested them.</span></span></em></p><h2>Don’t cut yourself on that edge</h2><p>First, it’s worth noting that “Bloody” isn’t actually the company name, or at least not where the brand started. Bloody has its roots in the much more reasonably named A4Tech, a company that’s been around a <em>long</em> time. I guess Bloody seems more...gamer-friendly? Kind of like Kingston and its HyperX sub-brand?</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_1-100787238-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_1-100787238-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787238" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>But suffice it to say: Any company that names its sub-brand <em>Bloody</em> has a certain aesthetic in mind, and much as I enjoy <em>typing</em> on the B975 I can’t say I’m a huge fan of its looks. First and foremost you have to get over the fact that the word “Bloody” is forever written on your keyboard, along with the accompanying faux-bloody handprint logo. You’re definitely going to draw some strange looks if you use the B975 in an office, I can tell you that. Be prepared for comments from anyone who visits your house too, at least if they’re left near your keyboard for any length of time.</p><aside class="emo emo-sb">
<h6 class="nav-title">Mentioned in this article</h6>
<div class="product-details">
<figure class="productFigure"><a href="https://www.pcworld.com/article/3287970/razer-huntsman-elite-keyboard-review.html" rel="noopener" target="_blank"><img src="https://images.idgesg.net/images/article/2018/07/img_20180706_202831-100764491-small.jpg" border="0" data-productid="1441120"/></a><a class="product-name" href="https://www.pcworld.com/article/3287970/razer-huntsman-elite-keyboard-review.html" data-productid="1441120">Razer Huntsman Elite</a></figure>

 <div class="product-lines"><div class="product-line1"><div class="rating"> <a href="https://www.pcworld.com/article/3287970/razer-huntsman-elite-keyboard-review.html"><span class="rating-star four-star"/></a></div><span class="product-brand"><a href="https://www.pcworld.com/article/3287970/razer-huntsman-elite-keyboard-review.html">Read PCWorld's review</a></span></div><div class="product-line2"><div class="price-msrp"><a class="product-list-price" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.razer.com%2Fgaming-keyboards-keypads%2Frazer-huntsman-elite&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&amp;xcust=US_001_3336148_005_1441120_web" target="_blank" data-product-name="Razer Huntsman Elite" data-vars-product-name="Razer Huntsman Elite" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.razer.com/gaming-keyboards-keypads/razer-huntsman-elite" data-product-id="1441120" data-vars-product-id="1441120" data-bkc="Hardware" data-bkmfr="Razer" data-vars-bkmfr="Razer" data-bkvndr="Razer" data-vars-bkvndr="Razer">$199.99</a><span class="msrp">MSRP $199.99</span></div><a class="btn-amazon" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.razer.com%2Fgaming-keyboards-keypads%2Frazer-huntsman-elite&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&amp;xcust=US_001_3336148_005_1441120_web" target="_blank" data-product-name="Razer Huntsman Elite" data-vars-product-name="Razer Huntsman Elite" data-vars-link-position-id="005" data-vars-link-position="Product Sidebar" data-po="vendor" data-vars-outbound-link="https://www.razer.com/gaming-keyboards-keypads/razer-huntsman-elite" data-product-id="1441120" data-vars-product-id="1441120" data-bkc="Hardware" data-bkmfr="Razer" data-vars-bkmfr="Razer" data-bkvndr="Razer" data-vars-bkvndr="Razer">See it</a></div><div class="product-line3 vendor"><a href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.razer.com%2Fgaming-keyboards-keypads%2Frazer-huntsman-elite&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3336148%2Fbloody-b975-gaming-keyboard-review.html&amp;xcust=US_001_3336148_005_1441120_web">on <span class="vendor-name">Razer</span></a></div></div></div>
</aside><p>Then there’s the lettering on the keycaps, which looks like an homage to the legendary mall-goth typeface <a href="https://www.dafont.com/bleeding-cowboys.font" rel="nofollow">Bleeding Cowboys</a> . (Appropriate, given the brand name.) Not only is it “edgy” in a somewhat embarrassing fashion, it’s nearly illegible on certain keys including Home, Delete, and Print Screen. The B975’s still usable, but those keys in particular look worn-out even fresh from the box, like pre-faded jeans or something.</p><p>It’s bizarre.</p><p>The rest isn’t as iffy, but odd choices still abound. There’s a strange bolt-head to the side of the NumLock indicator for instance. It stands out because it’s the only one of its kind on the entire keyboard, to the point where at first I thought it must have some purpose. But no, as far as I can tell it’s just the same faux-industrial look used by Cougar (for instance), only applied here in a somewhat random fashion.</p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_5-100787242-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_5-100787242-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787242" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small>
<figcaption>
<p>Why is this screw here? I don’t know.</p>
</figcaption>
</figure><p>Don’t worry, you’ll get your fill of screws though. The B975 ships with a detachable wrist rest, and anyone who’s ever touched a keyboard knows what that means: It clips in with little pieces of plastic, right? <em>Wrong</em>. Bloody intends for you to hold the B975’s wrist rest on with two tiny screws—and not thumb-screws either, but ones you need to dig out a screwdriver to turn. “Detachable” is a generous description here. Once this wrist rest is hooked in, you’re never going to take it off.</p><p>In theory, screws are better, sure. They’re more durable, more permanent, and won’t suddenly unclip from the keyboard like those tiny pieces of plastic. But you know what? I’d much rather take two seconds to snap those plastic bits in than two minutes messing with finicky little screws.</p><p>The B975 also comes with an alternate piece of plastic for the wrist rest—bright red, instead of the default black. And wouldn’t you know it: That’s <em>also</em> held on by two tiny screws. Bright red’s not my style, so I just didn’t bother replacing it. (The photo you’ll see below was taken by simply placing the alternate wrist rest on top of the original.)</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_9-100787246-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_9-100787246-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787246" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>And then there are the odd metal lines that separate the keyboard into a handful of distinct zones. There’s one underneath the Function row, two at either end of the keyboard, one between the main keyboard zone and the Arrow Keys/Home block. Why? I don’t know. It doesn’t really bother me, but nor would I say it’s a beautiful detail.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><p>The B975 is odd. That’s all. It doesn’t <em>feel</em> chintzy like the bargain-bin keyboards you’ll find on Amazon. The feet have a bit of flex, but overall the build quality is excellent. It <em>looks</em> somewhat cheap though—very much “Gaming Peripherals Circa 2007,” not circa 2019. Some people still love that aesthetic, but personally I’d rather have something a bit more minimalist. Hell, even Razer’s peripherals look more upscale, and I’m including the Huntsman Elite and its flashy RGB wrist rest in that pool.</p><p>It’s worth noting that the B975 is Bloody’s most normal keyboard, as well. I’m almost happy we didn’t source a review unit until now, because some of Bloody’s older designs are a real eyesore. I don’t know what the hell those plastic tumors on <a href="https://www.bloodyusa.com/product.php?pid=11&amp;id=129" rel="nofollow"> the B318 </a>are for instance, but I hate it.</p><h2>At the speed of light</h2><p>I hope Bloody continues to tone down its aesthetic though, because the B975 is otherwise a <em>fantastic</em> keyboard.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_8-100787243-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_8-100787243-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787243" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>For those who didn’t read our Huntsman Elite review, first let’s do a recap on optical switches. Your traditional mechanical switch works like this: You press a key, metal touches metal, that completes a circuit, and your keystroke is registered. Layman’s terms, but those are the basics. Optical switches basically cut out that “metal touches metal” portion, replacing it with light. Underneath every A4Tech LK Libra switch there’s a laser beam, interrupted by a piece of plastic. When you press a key this plastic dips out of the way, the two sides of the beam connect, and that in turn registers your keystroke.</p><p>According to A4Tech/Bloody, this gives you a competitive advantage. After all, the signal is being sent <em>at lightspeed!</em> That sounds cool and futuristic, yeah?</p><p>But as I said with the Huntsman Elite, it’s doubtful anyone can tell the difference. Sure, electrical signals travel slower than the speed of light. That’s fact. They don’t travel <em>that</em> much slower though, and the distances we’re talking about are a few millimeters long at most. It’s certainly not a difference you’d notice while typing. You might be saving <em>a single millisecond</em> at best—keeping in mind your PC’s overall latency is likely 30 to 60 milliseconds. A millisecond isn’t nothing, but for practical purposes it might as well be.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_6-100787245-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_6-100787245-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787245" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>That said, optical switches have some cool advantages that I wish Bloody (and Razer) would focus on more instead of trying to force this Elite Gamer Switches narrative. They’re much more resilient, for starters. The connections in standard mechanical switches wear out over time. It’d take years for you to notice, but they do. Most Cherry switches for instance are rated for a lifetime 50 million keystrokes—an order of magnitude more than rubber dome switches, but there’s still an end in sight.</p><p>Light is light, though. You don’t “wear out” light. A4Tech rates the LK Libra switch for 100 million keystrokes, and I have to imagine you’d wear a hole through the B975’s keycaps before reaching that number.</p><p>On a similar note: They’re spill resistant. It’s not impossible to waterproof a standard mechanical keyboard, but it’s difficult. Corsair’s K68 accomplishes it by semi-sealing the area around each switch with a rubber rim, for instance, but all that engineering work can still be defeated pretty easily. Because an optical keyboard’s circuitry is housed in the chassis, it’s relatively easy to seal up. The B975 isn’t <em>entirely</em> waterproof, but you can probably bleed all over it and it’ll be okay. (No such promise for whether <em>you’ll</em> be okay.)</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_4-100787239-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_4-100787239-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787239" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>But as with the Huntsman Elite, it’s really the switch itself that I’m most enamored with. Most of the time there’s an adjustment period when moving between switches, maybe a day or even a week where you get used to the resistance, the actuation point, all the small characteristics that separate one switch from another.</p><p>The LK Libra required no such adjustment period from me. Our Bloody B975 came equipped with the LK Libra Orange switches, which blend the tactile clicky feel of a Cherry MX Blue with the gaming-first mindset of something like the MX Silver.</p><p>What do I mean? Well, for the real keyboard nerds: The LK Libra Orange features a travel distance of 3.5mm, an actuation of 1.5mm, and requires 40 grams of force. Those numbers are much closer to the MX Silver’s (3.4mm, 1.2mm, and 45 grams) than they are to MX Blues (4mm, 2mm, 50 grams). And yet the LK Libra Orange also has the tactile click feel and sound I associate with MX Blues—and the keystrokes are smoother, to boot.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2019/02/bloody_b975_7-100787244-orig.jpg" rel="nofollow"><img src="https://images.idgesg.net/images/article/2019/02/bloody_b975_7-100787244-large.jpg" border="0" alt="Bloody B975" width="700" height="331" data-imageid="100787244" data-license="IDG"/></a> <small class="credit">IDG / Hayden Dingman</small></figure><p>They’re a joy to use. I still think I prefer the longer keystroke of a Cherry MX Blue for day-to-day typing, but this gives me somewhat of the same feel while also being slightly better suited for gaming. It’s a decent compromise, and I could definitely see LK Libra Oranges becoming my switches of choice in the long-term. At the very least they’re in the top three.</p><h2>Bottom line</h2><p>Using LK Libra Oranges means using one of Bloody’s keyboards though, and at the moment that’s a more questionable proposition. I don’t <em>hate</em> the B975 by any means, but I’m also not in love with the whole aesthetic. It’s better than Bloody’s past efforts, for sure, but there’s still only so far you can go with a bloody handprint branded on every keyboard. I think I’d prefer the old A4Tech branding. It’s not catchy, but at least it wouldn’t call so much attention to itself.</p><p>That said, if you can look past the aesthetic choices (or even like them), the B975 is a fantastic keyboard. And at a perpetual <a class="productLink" href="http://buy.geni.us/Proxy.ashx?TSID=14154&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-000-1442383-web-20" rel="nofollow" target="_blank" data-productid="1442383" data-product-name="Bloody B975" data-vars-product-name="Bloody B975" data-vars-link-position-id="000" data-vars-link-position="Body Text" data-po="amazon" data-vars-outbound-link="https://www.amazon.com/Strike-Optical-Gaming-Keyboard-Smooth/dp/B079HJCZ45?psc=1&amp;SubscriptionId=AKIAIVYSMSQJCH4VBFJA&amp;tag=pcworld02-20&amp;linkCode=xm2&amp;camp=2025&amp;creative=165953&amp;creativeASIN=B079HJCZ45" data-product-id="1442383" data-vars-product-id="1442383" data-bkc="Hardware" data-bkmfr="BLOODY" data-vars-bkmfr="BLOODY" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">Amazon sale price of $150</a> it’s a fair amount cheaper than the Huntsman Elite. If you’re looking to get started with optical switches, this is probably your best point of entry.</p>

	
	
		
	
	
	
	
		
		
		
		










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2008 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2008  blox4_html  blxC24068">To comment on this article and other PCWorld content, visit our <a href="https://www.facebook.com/PCWorld/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/pcworld" target="_blank">Twitter</a> feed.  </div>
		
	

	


</div>
	
	
</div>

	<script>
		try {
			performance.mark("mark_article_body_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
	</script>



	
	  
	


























	
	
	
	
	
	
	
	<div class="at-a-glance single expanded" data-tracking-category="ecomm-aag-expanded">
		
		<div class="product-list-header">At a Glance</div>
		<ul class="aag-list">
			
			
				
						
							
						
						
				
				
					
					
					
					
					
						
						
							
						
					
					
				
				<li class="aag-item single " data-product-id="1442383" >
					
						<div class="product-left">
						
						<span itemscope itemtype="http://schema.org/Product" itemprop="itemReviewed">
					
					
						
						
					
					<h3 class="product-name expandable" itemprop="name" title="View More Details">
						
							
							Bloody B975
						
					</h3>
					</span>
					
						
						
						
							
							<div class="rating" itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"><span class="rating-star four-star"></span><meta itemprop="ratingValue" content="4.0"></div>
							
							
							
							
						
					</div>
										
					
					<div class="product-right">
						
						
						<div class="price-msrp">
							
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-002-1442383-web-20" target="_blank" rel="nofollow" class="product-list-price trackLink" data-product-id="1442383" data-po="amazon" data-bkc="Hardware" data-bkmfr="BLOODY" data-bkvndr="Amazon" data-product-name="Bloody B975" data-vars-product-id="1442383" data-vars-bkmfr="BLOODY" data-vars-bkvndr="Amazon" data-vars-product-name="Bloody B975" data-vars-outbound-link="https://www.amazon.com/Strike-Optical-Gaming-Keyboard-Smooth/dp/B079HJCZ45?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=pcworld02-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B079HJCZ45" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">$149.99</a>	
							
													</div>
						<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-002-1442383-web-20" target="_blank" rel="nofollow" class="btn-amazon trackLink" data-product-id="1442383" data-po="amazon" data-bkc="Hardware" data-bkmfr="BLOODY" data-bkvndr="Amazon" data-product-name="Bloody B975"  data-vars-product-id="1442383" data-vars-bkmfr="BLOODY" data-vars-bkvndr="Amazon" data-vars-product-name="Bloody B975" data-vars-outbound-link="https://www.amazon.com/Strike-Optical-Gaming-Keyboard-Smooth/dp/B079HJCZ45?psc=1&SubscriptionId=AKIAIVYSMSQJCH4VBFJA&tag=pcworld02-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B079HJCZ45" data-vars-link-position-id="002" data-vars-link-position="AAG Bottom">See it</a>
						<div class="vendor">
							<a href="http://buy.geni.us/Proxy.ashx?TSID=14154&GR_URL=https%3A%2F%2Fwww.amazon.com%2FStrike-Optical-Gaming-Keyboard-Smooth%2Fdp%2FB079HJCZ45%3Fpsc%3D1%26SubscriptionId%3DAKIAIVYSMSQJCH4VBFJA%26tag%3Dpcworld02-20%26linkCode%3Dxm2%26camp%3D2025%26creative%3D165953%26creativeASIN%3DB079HJCZ45%26ascsubtag%3DUS-001-3336148-002-1442383-web-20" target="_blank" rel="nofollow">on <span class="vendor-name">Amazon</span></a>
						</div>
					</div>
					
				
				<div class="expanded-content">
					<p  itemprop="description" class="expanded-desc">Bloody's B975 makes a number of questionable aesthetic choices, but its LK Libra Orange optical switches might become your new favorite—provided you like a loud and clicky tactile switch.</p>
					
						
							<div class="product-pros">
								<h4>Pros</h4>
								<ul>
								
									<li>LK Libra Orange optical switch is durable and great to type on</li>
								
									<li>Great build quality</li>
								
									<li>A relatively cheap entry-point for optical switches</li>
								
								</ul>
							</div>
						
						
							<div class="product-cons">
							<h4>Cons</h4>
								<ul>
								
									<li>Wrist rest requires a screwdriver to attach</li>
								
									<li>Odd (or even ugly) aesthetic choices</li>
								
									<li>The word "Bloody" is written on the keyboard—forever</li>
								
								</ul>
							</div>
						
					
				</div>
				
				
			</li>
			
		</ul>
	</div>





<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	
	
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>






    <div class="apart-alt tags">
    <span class="related">Related: </span>
    <ul>
		
			<li><a class="edition-link-url primary-cat-url2" href="/category/hardware"><span class="primary-cat-name2">Hardware</span></a></li>
		
			<li><a class="edition-link-url primary-cat-url2" href="/category/input-keyboards"><span class="primary-cat-name2">Keyboards</span></a></li>
		 
		
			
			
				 
					 
			    				
				
			
				
		
    </ul>
   
	</div>









		
   		
		












		
	
	
	
	<div class="byline vcard author end-byline">	
		<div class="author-info" id="haydendingman">		
			
			
				<p>Hayden writes about games for PCWorld and doubles as the resident Zork enthusiast.</p>
					
		</div><!-- end .author-info -->	
		
		<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Hayden-Dingman/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					<li>
						<a href="https://twitter.com/haydencd" class="twitter-follow" target="_blank">
							<i class="ss-icon ss-social ss-twitter"></i>
						</a>
					</li>
					
					
					
				</ul>
			</div>
			
	</div>
	
	
		
		
		




	 





	
	


















 




	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20190321115630"></script>


					










				
			
		
		</section><!-- /.bodee -->

		















		
			
				

















<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="PCWorld_1"></div>  
</div>
<script>
	var obEdition = edition ||  countryCode || '';
	var widgetId="";
	
	if (obEdition === "asean") {
		widgetId="AR_3"
		if ($("body").hasClass("slideshow")) {
			widgetId="AR_4"
		}
	}
	if (widgetId !== "") {
		$(".OUTBRAIN").attr("data-widget-id", widgetId);
	}
	$.getScript("//widgets.outbrain.com/outbrain.js");
</script>


			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=54ab7a69-a67d-4f7f-8f8c-cef18fa3f42f">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20190321115630" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,6);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Today's Special Offers</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					html += "<span>"+selectedAds[i].body+"</span>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20190321115630" />
<link rel="stylesheet" href="/www.idgcsmb.pcw/css/footer.css?v=20190321115630" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="http://pcworld.com" id="footer-logo-pcw" class="ir">PCWorld</a>
    		<p>PCWorld helps you navigate the PC ecosystem to find the products you want and the advice you need to get the job done.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="/faq" rel="nofollow">Digital Magazine</a></li>
				<li><a href="https://ssl.palmcoastd.com/31402/apps/PCWDIGITALGIFT?ikey=I**GF2">Gift Subscription</a></li>
				<li><a href="https://www.idg.com/about-adchoices-pcworld/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://shop.pcworld.com">Shop</a></li>
				<li><a href="/couponcodes">Coupon Codes</a>
					<ul>
						<li><a href="/couponcodes/aliexpress">Aliexpress</a></li>
						<li><a href="/couponcodes/ebay">Ebay</a></li>
						<li><a href="/couponcodes/home-depot">Home Depot</a></li>
						<li><a href="/couponcodes/hp">HP</a></li>
						<li><a href="/couponcodes/jcpenney">jcpenney</a></li>
						<li><a href="/couponcodes/oneplus">OnePlus</a></li>
						<li><a href="/couponcodes/walmart">Walmart</a></li>
						<li><a href="/couponcodes/target">Target</a></li>
						<li><a href="/couponcodes/6pm-com">6PM</a></li>
					</ul>
				</li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>			
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>PCWorld Categories</h2>
    		<ul>
    			<li><a href="/category/business/">Business</a></li>
				
				<li><a href="/category/laptop-computers/">Laptops</a></li>
				<li><a href="/category/mobile/">Mobile</a></li>
				<li><a href="/category/computers-all/">PC Hardware</a></li>
				
				<li><a href="/deals">Deals</a></li>
			</ul>
			<ul class="right">
				<li><a href="/category/printers/">Printers</a></li>
				<li><a href="/category/security/">Security</a></li>
				<li><a href="/category/software/">Software</a></li>
				<li><a href="/video/">Videos</a></li>
				<li><a href="/category/windows/">Windows</a></li>
			</ul>

			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="https://www.idg.com/advertise-with-us/pcworld/" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
				<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<div id="footer-subscribe" class="clearfix">
	    		<a href="https://ssl.palmcoastd.com/31402/apps/PCWDIGITAL?ikey=I**A02">
	    			<img src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png" alt="PCWorld Magazine Cover">
	    			<h2>Get PCWorld's Digital Editions</h2>
	    			<span class="btn-link">Subscribe Now</span>
	    		</a>
    		</div>
    		<div id="footer-social">
    			<span>Follow us</span> <a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					
						<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
							&#xF630;
						</a>
					 			    			
    		</div>
    		
    		 <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
		                
		                	
		                













	
		<option value="https://www.gamestar.com">GameStar</option>
	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	

		            </select>
		    </div>
		    
		    <div class="copyright">
		    	<img src="https://alt.idgesg.net/images/logos/logo-footer-white.png" alt="IDG Communications" />
				<p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2019 IDG Communications, Inc.</small></p>		    
			</div>
    	</div>
    </div> 
</footer>
 


		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		
















<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


	<script>
		$(document).ready(function() {
			if (typeof $.cookie("geoPromoDontShow") === 'undefined' && typeof $.cookie("geoPromoSeen") === 'undefined' && navigator.languages.indexOf("es") > -1 && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)) {
				$.get("/napi/tile?def=international.promo", 
					function(data) {
						$("body").prepend(data);
						var visitTime = new Date();
						visitTime.setTime(visitTime.getTime()+1000*60*60*24); //24 hours
				      	$.cookie('geoPromoSeen', 'true', { expires: visitTime, path: '/' });
						$(".geo-promo .ss-delete, a.cont-here, a.dont-show").click(function(e) {
							e.preventDefault();
							if ($(this).is(".dont-show")) {
								visitTime.setTime(visitTime.getTime()+1000*60*60*24*30); //30 days
						      	$.cookie('geoPromoDontShow', 'true', { expires: visitTime, path: '/' });
							}
							$(".geo-promo").fadeOut(function() {$(".geo-promo").remove()})
						});
					}
				);
			}
		});
	</script>

<script src="/www.idgcsmb/js/thm_post.js?v=20190321115630"></script>

<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>











<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>
$(function() {
    $("img.lazy").lazyload({ 
    	effect : "fadeIn", 
    	threshold: 200,
    	failure_limit:25
    });
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>




	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	
	$(document).ready(function(){

		$('#extra-nav-toggle a').click(function(){
			if($(this).hasClass('open')){
				$('#extra-nav').hide();
				$(this).removeClass('open');
				$('#extra-nav-toggle a').removeClass('ss-delete');
				$('#extra-nav-toggle a').addClass('ss-dropdown');		
			} else {
				$('#extra-nav').show();
				$(this).addClass('open');
				$('#extra-nav-toggle a').removeClass('ss-dropdown');
				$('#extra-nav-toggle a').addClass('ss-delete');					
			}
			return false;
		});
		
		var isMobile = window.matchMedia("only screen and (min-width: 60.625em)");

    	if (isMobile.matches) {	
    		
			$('li.dealsNav').mouseenter(function(){
			    $(".dealsList").css({ 'display':'block'});
			});           
		
			$('ul.dealsList').mouseleave(function(){  
			    $(".dealsList").css({ 'display':'none'});	    
			});
		
		}
		  				  
	});//-- end document Ready
		
	


	g_bRequireHttps = true;
	 
		$.ajax('/ads/tso',{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	




 		
		










<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"pcw","e":"view","t":"article","id":"3336148"});
	
});
</script>
	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20190321115630  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
			
	</body>
</html>
