










<!DOCTYPE html>


	
	
		
	
		
	
	
	
	

<html lang="en">
	












<head>
		
	<meta charset="utf-8" />
	<title>Windows 7's support deadline may expire in July, if you don't apply this patch | PCWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	












<script>
!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://spiffymachine.com/v2/0/vfk2oJkpFG3vht2YK9N27PTefzTe3eLddsxvafcpjop9vedvRUWqqRmxuxgdcJYUfd9",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,a,n){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var n=o();if(n){var r=t[e].pubads();typeof r.setTargeting===a&&r.setTargeting("admiral-engaged","true")}}n=t[e]=t[e]||{},n.cmd=n.cmd||[],typeof n.pubads===a?r():typeof n.cmd.unshift===a?n.cmd.unshift(r):n.cmd.push(r)}(window,"googletag","function");;;;!function(t,e,a,n){function o(){if(!window.frames[n]){var e=t.body;if(e){var a=t.createElement("iframe");a.style="display:none",a.name=n,e.appendChild(a)}else setTimeout(o,5)}}function r(){for(var t=[],a=0;a<arguments.length;a++)t.push(arguments[a]);i.q=i.q||[],"ping"===t[0]?t[2]({gdprAppliesGlobally:e.__cmpGdprAppliesGlobally||!1,cmpLoaded:!1},!0):t.length&&i.q.push(t)}function c(t){try{return JSON.parse(t)}catch(e){}}function s(t){if(t){var e,a="__cmpCall",n="string"==typeof t.data&&t.data.indexOf(a)>=0;e=n?(c(t.data)||{})[a]:(t.data||{})[a],e&&i(e.command,e.parameter,function(a,o){var r={__cmpReturn:{returnValue:a,success:o,callId:e.callId}};t.source.postMessage(n?JSON.stringify(r):r,"*")})}}var i=e[a];o(),"function"!=typeof i&&(i=e[a]=r,e.addEventListener?e.addEventListener("message",s,!1):e.attachEvent&&e.attachEvent("onmessage",s))}(document,window,"__cmp","__cmpLocator");;
</script>

<script>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</script>




	
    <script src="/www/js/init_device.js"></script>    
    
    
    
		














<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20190219115147"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_PCWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "windows_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/windows');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'software,security,business');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3341800');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'microsoft');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", [3034,3404,2206,4846]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['windows','microsoft','security','business']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", [226,804,941,1177]);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Mark Hachman');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
		try {
			IDG.GPT.addTarget("tagNames", 'Windows 7');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20190219115147"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>
<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>

	

	

    <link rel="canonical" href="https://www.pcworld.com/article/3341800/windows/windows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html" />
	
	
	
	
	
	<meta name="description" content="Microsoft&#039;s shift to an updated, more secure hashing algorithm for delivering its patches means that Windows 7 support may expire sooner than expected." />
	
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/02/security_automation_locks_assembly_line_by_just_super_gettyimages-934439262_2400x1600-100788416-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2019-02-19" />
			<meta name="date" content="2019-02-19" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.pcworld.com/article/3341800/windows/windows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.amp.html" />

	
		<script type="text/javascript" src="//fonts.staticworld.net/ehr0jod.js"></script>
		<script type="text/javascript">try{Typekit.load();}catch(e){}</script>
	
	
	<meta property="twitter:account_id" content="6070762" />
	<meta property="fb:app_id" content="1542125639335283" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.pcworld.com/article/3341800/windows/windows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html">
    <meta property="og:site_name" content="PCWorld">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2019/02/security_automation_locks_assembly_line_by_just_super_gettyimages-934439262_2400x1600-100788416-large.3x2.jpg">
    	<meta property="og:image:width" content="700">
    	<meta property="og:image:height" content="467">
    
    
    
    
    
    
    	<meta property="og:title" content="Windows 7's support deadline may expire in July, if you don't apply this patch"> 
    
    
    <meta property="og:description" content="Microsoft&#039;s shift to an updated, more secure hashing algorithm for delivering its patches means that Windows 7 support may expire sooner than expected.">
    
    
		<meta property="fb:pages" content="7352931005" />
	

	
	<meta name="displaytype" content="article" />
	
	<meta name="source" content="pcworld" />
	
	<meta name="category" content="windows,microsoft,security,business" />
	
	<meta name="storytype" content="news" />
	
	<meta name="tags" content="windows 7" />
	
	
	
		<meta name="google-site-verification" content="FjWdymWSdutZJ-XIYfqJXlQZbLR7hMWmkwR5MQ0yqeY" />
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20190219115147" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20190219115147" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.pcw/css/inline-header.css?v=20190219115147" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20190219115147" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-layout.css?v=20190219115147" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20190219115147" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-colors.css?v=20190219115147" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20190219115147" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-typography.css?v=20190219115147" rel="stylesheet" />
	
	
	
	
		
		
			
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20190219115147" />	
			
			
		<link href="/www.idgcsmb.pcw/css/article.css?v=20190219115147" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20190219115147" rel="stylesheet" media="all" />
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
		<script>
		try {
			performance.mark("mark_head_css_done_blocking");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.pcw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed.png" />
	
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Mark Hachman";
			
		
			
			
	_sf_async_config.sections="windows";	
		
		
		
		
	_sf_async_config.domain = "pcworld.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Microsoft&#039;s shift to an updated, more secure hashing algorithm for delivering its patches means that Windows 7 support may expire sooner than expected.">
	
	
		
			<meta name="twitter:site" content="@pcworld">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/02/security_automation_locks_assembly_line_by_just_super_gettyimages-934439262_2400x1600-100788416-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="Windows 7&#039;s support deadline may expire in July, if you don&#039;t apply this patch">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.pcworld.com">
				
			
		
		
		
		
		
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.pcworld.com/",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.pcworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	
	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
	<script>
	var supMontMods = false;
	</script>
	


	
	
			
			
				
					
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		
















	


			
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	 
	 
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	 
	 
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
		
	
	
	<script>
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	dataLayer=[{
		'articleId': '3341800',
		'articleDisplayId':'1',
		'articleTitle': 'Windows 7\'s support deadline may expire in July, if you don\'t apply this patch',
		'articleType': 'News',
		'audience':'consumer',
		'author':'Mark Hachman',
		'blogName':'',
		'brandpost': '',
		'categoryIdList':'3034,3404,2206,4846',
		'categoryIdPrimary': '3034',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2019-02-19',
		'dateUpdated':'2019-02-19',
		'daysSincePublished':'0',
		'daysSinceUpdated':'0',
		'displayType':'article',
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-739745-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '226',
		'goldenTaxonomyIdList': '804,941,1177',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'windows',
		'ancestorGoldenCategories': '',
		'primaryCategoryList': 'microsoft,security,business',
		'primaryAncestorCategoryList': 'windows',
		'property': 'pcworld',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'skimlinksId':'111346X1569483',
		'source':'pcworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': 'windows 7',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'articleHasVideo':'false',
		'prodNames':prodNames.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodCategories':prodCategories.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1)	
	}];
	</script>
	 
	
	
	
		













		
			<!-- Page hiding snippet (recommended)  -->
			<style>.async-hide { opacity: 0 !important} </style>
			<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
			h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
			(a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
			})(window,document.documentElement,'async-hide','dataLayer',4000,
			{'GTM-KVP87FZ':true});</script>
			<!-- Modified Analytics tracking code with Optimize plugin -->
			    <script>
			    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			
			 // We need to create the UA tracker here in order to link it to Optimize - even though everything else is in GTM
			  ga('create', 'UA-739745-1', 'auto', {'useAmpClientId': true});  
			  ga('require', 'GTM-KVP87FZ');           
			  
			</script>

	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>




	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-K7239P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-K7239P');</script>
	<!-- End Google Tag Manager -->

	
		<script>
			try {
				performance.mark("mark_head_js_done_blocking");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");

			}
		</script>
	
	
	
	
		<script>
			function bindPerformanceMarks(){
			//even though it's called slotRenderEnded, it's the first thing to happen -  corresponds to when we get a response back from DFP
			googletag.pubads().addEventListener('slotRenderEnded', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial' && !event.isEmpty) {//also ensure it's not an empty ad response
					performance.mark("mark_welcome_render_begin");
				}
			});
			googletag.pubads().addEventListener('slotOnload', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_render_end");
				}
			});
			googletag.pubads().addEventListener('impressionViewable', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_impression_viewable");
									
					//send user timings here; otherwise we can't guarantee these events will have fired
					w = performance.getEntriesByType("mark").filter(function(mrk) {
						return mrk.name.indexOf("mark_welcome") > -1; //filter to only get welcome-ad-related marks
					});
					gtmEvent = {'event': 'gatherWelcomeAdMarks'};
						for (var j=0; j < w.length; j++) {
							console.log ("+++Mark only entry[" + j + "]: name = " + w[j].name + "; startTime = " + w[j].startTime);
							gtmEvent[w[j].name] = w[j].startTime;
						}
						var dataLayer = window.dataLayer = window.dataLayer || [];
							dataLayer.push(gtmEvent);
						}
					});
				}
				try {
					IDG.GPT.googleCommandPush(bindPerformanceMarks);
				}
				catch(e){
					console.log('error binding performance marks: ' + e);
				}
		</script>
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script async src="//js-sec.indexww.com/ht/p/187051-133464700288038.js"></script>
	
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	
	
	
	
	
	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'Microsoft\'s shift to an updated, more secure hashing algorithm for delivering its patches means that Windows 7 support may expire sooner than expected.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'Microsoft\'s shift to an updated, more secure hashing algorithm for delivering its patches means that Windows 7 support may expire sooner than expected.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-02-19T14:18:04Z",
	        publishedAt: "2019-02-19T14:18:04Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [226,],
	        secondaryIds: [804,941,1177,226]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  window.permutive.track('User', {
			  companySize: null,
			  country: null,
			  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
			  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
			  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
			  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
			})
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
</head>

	<body id="article3341800" class="article pcworld">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			
		  		<script type="text/javascript">
		  		
		  		
				document.write('<div id="gpt-superstitial" class=" ad-container"></div>');
				consent.ads.queue.push(function(){
			  		try {			  			
			   			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
			   			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
			   			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
			   		}
					catch (exception) {
						console.log("Error with IDG.GPT: " + exception);
					}
		  		});
				
				</script>
		
		
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		















	

		
			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	













<div id="page-top">
		<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
		<link itemprop="url" href="http://www.pcworld.com"> 
	    




<div class="network-header">
		<div class="network-header-inner">
			<div id="network-tools">

				<div id="saved-comparisons"></div>				
				<ul class="hmenu" id="heroLogin">				
					<li class="subscribeHeader"><a href="/magazines">Subscribe</a><div class="subscribe-hover" style="">
                        <div class="pointer">&#9650;</div>
                        <span>Learn more about PCWorld's Digital Editions</span>
                        <img alt="PCWorld Magazine Cover" src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png">
                      </div></li>
					
				</ul>
			</div><!-- /#network-tools -->

				<div id="network-social">					
                  
					
					<a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
						&#xF630;
					</a>

				<form id="search-form" action="/search">
					<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
					<input type="submit" name="submit" id="banner-search-submit" value="search" />
					<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
				</form>

				</div><!-- /#network-social -->
			
				
		</div>
	</div><!-- /.network-header -->


	<header id="banner">
		<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
		<div id="logo">
			<a href="/" class="ir banner-logo" id="logoImage">Home</a>		
		</div>
		<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
	</header>


	



















<div id="main-nav">
	<div class="container clearfix">
		<ul class="fmenu" id="panel-nav">
			<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
			
			
				<li class="dealsNav"><a href="/deals" id="dealsNav">Deals <span class="ss-dropdown right"></span></a> 
					<ul class="dealsList">
						<li><a href="/deals" id="dealsNav">Deals</a></li>
						<li><a href="https://www.pcworld.com/couponcodes">Coupon Codes</a></li>
						<li><a href="https://shop.pcworld.com">Shop</a></li>
					</ul>
				</li>
			

		</ul>

		<ul class="fmenu" id="site-nav">
			
				<li><a href="/category/business/">Business</a>
					
				</li>
			
				<li><a href="/category/laptop-computers/">Laptops</a>
					
				</li>
			
				<li><a href="/category/smartphones/">Smartphones</a>
					
				</li>
			
				<li><a href="/category/hardware/">Hardware</a>
					
				</li>
			
				<li><a href="/category/security/">Security</a>
					
				</li>
			
				<li class="selected"><a href="/category/software/" class="active">Software</a>
				
					<ul>
						
								
									
									
										<li><a href="/category/software-security/">Security</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-games/">Games</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-productivity/">Productivity Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-music/">Home Audio</a></li>
									
													
						
								
									
									
										<li><a href="/category/business-software/">Business Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/photography/">Photography</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-utilities/">Utility Software</a></li>
									
													
						
								
									
									
										<li class="sub-selected"><a href="/category/windows/">Windows</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-social/">Social networking</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-entertainment/">Entertainment Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/operating-systems/">Operating Systems</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-development/">Development</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-education/">Education Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-graphics/">Graphics and Design Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-health/">Health and Fitness Software</a></li>
									
													
						
								
									
										<li><a href="/product/directory?sortOrder=best&categoryId=3086&priceRange=#directoryForm">Medical Software</a></li>
									
									
													
						
								
									
									
										<li><a href="/category/software-lifestyle/">Lifestyle Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-navigation/">GPS and Navigation</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-news/">News Software</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-reference/">Reference</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-sports/">Sports</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-travel/">Travel</a></li>
									
													
						
								
									
									
										<li><a href="/category/videos/">Video</a></li>
									
													
						
								
									
									
										<li><a href="/category/web-apps/">Web Apps</a></li>
									
													
						
								
									
									
										<li><a href="/category/software-weather/">Weather</a></li>
									
													
						
								
									
									
										<li><a href="/category/browsers/">Browsers</a></li>
									
													
						
					</ul>
					
				</li>
			
				<li><a href="/category/gadgets/">Gadgets</a>
					
				</li>
			
			<li class="displayMobileOnly"><a href="/magazines">Subscribe</a></li>
			
		</ul>
		
			<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
			
			<div id="extra-nav">
				<ul>
					
						<li><a href="/resources/">Resources</a></li>
					
						<li><a href="/category/computers/">PCs</a></li>
					
						<li><a href="/category/smartphones/">Smartphones</a></li>
					
						<li><a href="/category/printers/">Printers</a></li>
					
						<li><a href="/category/ultrabooks/">Ultrabooks</a></li>
					
					<li><a href="/blogs">Blogs</a></li>
				</ul>
				<ul>
					
						<li><a href="/category/antivirus-software/">Viruses</a></li>
					
						<li><a href="/category/cameras/">Cameras</a></li>
					
						<li><a href="/category/components/">Components</a></li>
					
						<li><a href="/category/computers-accessories/">Computer Accessories</a></li>
					
						<li><a href="/category/consumer-advice/">Consumer Advice</a></li>
					
						<li><a href="/category/digital-assistants/">Digital Assistants</a></li>
					
						<li><a href="/category/displays/">Displays</a></li>
					
						<li><a href="/category/e-readers/">E-readers</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/components-graphics/">Graphics Cards</a></li>
					
						<li><a href="/category/storage-drives/">Hard Drives</a></li>
					
						<li><a href="/category/home-theater/">Home Theater</a></li>
					
						<li><a href="/category/input-devices/">Input Devices</a></li>
					
						<li><a href="/category/input-keyboards/">Keyboards</a></li>
					
						<li><a href="/category/laptop-accessories/">Laptop Accessories</a></li>
					
						<li><a href="/category/mobile/">Mobile</a></li>
					
						<li><a href="/category/networking/">Networking</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/operating-systems/">Operating Systems</a></li>
					
						<li><a href="/category/storage-optical/">Optical Drives</a></li>
					
						<li><a href="/category/components-processors/">Processors</a></li>
					
						<li><a href="/category/servers/">Server Hardware</a></li>
					
						<li><a href="/category/smartwatches/">Smartwatches</a></li>
					
						<li><a href="/category/streaming-services/">Streaming Services</a></li>
					
						<li><a href="/category/storage/">Storage</a></li>
					
						<li><a href="/category/tablets/">Tablets</a></li>
					
						<li><a href="/category/windows/">Windows</a></li>
					
				</ul>
			</div>
		
	</div>
</div>	<!--/#main-nav-->


<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/software-security/">Security</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/software-games/">Games</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/software-productivity/">Productivity Software</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/software-music/">Home Audio</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/business-software/">Business Software</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/photography/">Photography</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/software-utilities/">Utility Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/windows/" class="active">Windows</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-social/">Social networking</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-entertainment/">Entertainment Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/operating-systems/">Operating Systems</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-development/">Development</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-education/">Education Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-graphics/">Graphics and Design Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-health/">Health and Fitness Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
								<a href="/product/directory?sortOrder=best&categoryId=3086&priceRange=#directoryForm">Medical Software</a>
							
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-lifestyle/">Lifestyle Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-navigation/">GPS and Navigation</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-news/">News Software</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-reference/">Reference</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-sports/">Sports</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-travel/">Travel</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/videos/">Video</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/web-apps/">Web Apps</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/software-weather/">Weather</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/browsers/">Browsers</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->










		</div> 
	</div> 




			<!-- Events Header -->
		
			
				
				 
					
						
						
						
						
						
							
								
				   				
				   				
				   					    			
						
					
					
					
					
					
				
				 
				 
				 
				 
				  
				   
				  
				  
				 
				 
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	


		


<script>
$(document).ready(function(){
	$('.searchbox-input-class').each(function(){
	    $(this).change(function(){
	    	var qStr=$(this).val();
	    	if($(this).val().indexOf('@')!=-1){
	    		qStr=qStr.replace(/@/g,' ');
	    		$(this).val(qStr);
	    	}
	    });
	});
});
</script>


		
		











<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main">

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		











	
	























	
			















<header  class='cat'>

	
	
	
	
	
	
	
	
	
		<!-- CSMB Horizontal Responsive -->
<ins class="adsbygoogle"
     style="display:block;"
     data-ad-client="ca-pub-4268075595326305"
     data-ad-slot="9945794902"
     data-ad-format="link"></ins>


<script>
consent.ads.queue.push(function(){
	$.getScript( "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" )
		  .done(function( script, textStatus ) {
		    //need to add  && publisherConsents.gdprApplies back to the end of this conditional after testing
			  if (!consent.personalization && consent.isEU)  {
				   (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1
				   console.log('*****GDPR: loaded adsense in non-personalized mode')
			  }
			  else {
			   		(adsbygoogle = window.adsbygoogle || []).push({});
			   	 	console.log('*****GDPR: loaded adsense in normal mode');
			  } 
		  })
		  .fail(function( jqxhr, settings, exception ) {
		    console.log( "Triggered ajaxError handler." );
		});
});
</script>
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a href="/category/windows/" itemprop="url"><span itemprop="title">Windows</span></a></li>
				
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
		
		
			<div class="category"><a href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">Windows 7's support deadline may expire in July, if you don't apply this patch</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">If you're running Windows 7 and regularly update your PC, you should be fine. Windows 10 users aren't affected. </h3>
		</section>
	
	
	
	
			<div class="cat-social">
				
					
				


















	

				

	
	
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3341800%2Fwindows%2Fwindows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3341800%2Fwindows%2Fwindows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html&via=pcworld&text=Windows+7%27s+support+deadline+may+expire+in+July%2C+if+you+don%27t+apply+this+patch" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a class="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3341800%2Fwindows%2Fwindows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html&description=Windows+7%27s+support+deadline+may+expire+in+July%2C+if+you+don%27t+apply+this+patch" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/pinterest.svg" />
		</a>
	</li>
	<li class="sosh">
		<a href="http://reddit.com/submit?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3341800%2Fwindows%2Fwindows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html&title=Windows+7%27s+support+deadline+may+expire+in+July%2C+if+you+don%27t+apply+this+patch" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="#email" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>
<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}	
function bindEmailModal() {
	$('#emailModal').on("click",".close-btn",function(event) {
		event.preventDefault();
        $('#emailModal').hide();
        $("#emailModal .eml-friend").show();
        $(".eml-friend-success").hide();
        $(".eml-friend-error").hide();
		$('#emailModal').fadeOut(200);
		$('#email-to').val('');
		$('#email-from').val('');
		$('#name').val('');
		$('#personalization').val('');
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
	});

	$('#emailModal').on("submit","form",function(event) {
		event.preventDefault();
		var $form = $(this);
		var action = $form.attr('action');
		var formData = $form.serialize();
		var emailFrom = $('#email-from').val();
		var emailTo = $('#email-to').val();
		var uresponse=$('#g-recaptcha-response').val();
		$('#eml-from-address-message').html("");
		$('#eml-to-address-message').html("");
		$('#eml-friend-captcha-message').html("");
		if (isValidEmailAddress(emailFrom) && isValidEmailAddress(emailTo) && uresponse !="") {
			// eloqua
			
			// email
			$.ajax(action, {
				type: 'POST',
				data: formData,
				success: function(data, textStatus, xhr) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-success").fadeIn(800);	
				},
				error: function(xhr, textStatus, errorThrown) {
					$("#emailModal .eml-friend").hide();
					$(".eml-friend-error").fadeIn(800);						
				}
			});
		}
		else {	
			if(uresponse==""){
				$('#eml-friend-captcha-message').html("Please verify you're not a robot!");	
			}
			if(!isValidEmailAddress(emailTo)){
			  $('#eml-to-address-message').html("Please enter a valid email address.");		
			}
			if(!isValidEmailAddress(emailFrom)){
			  $('#eml-from-address-message').html("Please enter a valid email address.");		
			}
		}
	});
} //bindEmailModal() end

$(document).ready(function() {
	$(document).on("click","#email-icon",function(event) {
		event.preventDefault();
		bindEmailModal();
		$('#emailModal').fadeIn(800);
	});
});
</script>
<div class="modal eml-friend-wrapper" id="emailModal" style="display:none;">	
	<form class="eml-friend" action="/eloquaemail/article?eloqua=false&id=3341800">
		<input type="hidden" name="title" value="Windows 7\'s support deadline may expire in July, if you don\'t apply this patch" />
		<input type="hidden" name="url" value="https://www.pcworld.com/article/3341800/windows/windows-7s-support-deadline-may-expire-in-july-if-you-dont-apply-this-patch.html" />
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Email a friend</h3>

		<div class="input-row">
			<div id="eml-to-address-message" class="error-msg"></div>
			<h4 class="input-label">To</h4>
			<input id="email-to" value="" placeholder="Email address (required)" type="email" name="recipients" tabindex="1">
			<p class="addl-text">Use commas to separate multiple email addresses</p>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-from-address-message" class="error-msg"></div>
			<h4 class="input-label">From</h4>
			<input id="name" value="" placeholder="Name (optional)" type="text" name="name" tabindex="2">
		</div>
		<div class="input-row">
			<input id="email-from" value="" placeholder="Email address (required)" type="email" name="sender" tabindex="3">
		</div>
		<div class="input-row">
			<textarea name="message" placeholder="Check out this article I found on PCWorld." id="personalization" tabindex="4"></textarea>
		</div>
		<hr />
		<div class="input-row">
			<div id="eml-friend-captcha-message" class="error-msg"></div>
		
		
 			











<script src="https://www.google.com/recaptcha/api.js" async defer></script>

<div class="g-recaptcha" data-sitekey="6LczmkcUAAAAANEO7J277KwH6Kzp6BEQjPTWP4S4"></div>
 		</div>
		<hr />
		<div class="submit">
			<input type="submit" value="Send" class="input-submit" tabindex="5">
			<a href="/about/privacy.html" class="submit-privacy" target="_blank">Privacy Policy</a>
		</div>
	</form>

	<div class="eml-ty eml-friend-success" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Thank you</h3>
		<p class="msg-sent">Your message has been sent.</p>
	</div>
	<div class="eml-friend-error" style="display:none;">
		<a href="#" class="close-btn"><i class="ss-icon ss-delete"></i></a>
		<h3>Sorry</h3>
		<p class="msg-sent">There was an error emailing this page.</p>
	</div>
</div>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Mark-Hachman/" rel="author" title="Mark Hachman"><img  class="bylineImage  imgId100629551 " src="https://images.techhive.com/images/article/2015/11/headshot-crop-100629551-byline.jpg" width="34" width="34" alt="Mark Hachman" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Mark-Hachman/"><span itemprop="name">Mark Hachman</span></a></span>
						</p>
						<p class="dateline">
						
							Senior Editor, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">PCWorld</span><meta itemprop="logo" content=""/></span> <span class="divider break">|</span>
							
										
							<span class="pub-date" class='break-date' itemprop="datePublished" content="2019-02-19T14:18-0800">Feb 19, 2019 2:18 PM
								 PT
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	
	
	
	
		<div class="lede-container">
			
			
			
				
				
					
		                
		                	
		                	
		                
		                
						
						
						
					
					
					
					
					<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
						<meta itemprop="representativeOfPage" content="1" />
						<meta itemprop="height" content="467" />
						<meta itemprop="width" content="700" />
			    		
			    		<img src="https://images.idgesg.net/images/article/2019/02/security_automation_locks_assembly_line_by_just_super_gettyimages-934439262_2400x1600-100788416-large.jpg" alt="Security automation: locks on an assembly line." itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
			    		
				    		<script>
				    			try {
				    				performance.clearMarks("mark_primary_img_rendered");
									performance.mark("mark_primary_img_rendered");
				    			}
				    			catch(e) {
				    				console.log("Error saving performance mark -- this function may not be supported in this browser");
				    			}
							</script>
						
			    		<figcaption>
			    			
			    			
			    				<span class="credit" itemprop="copyrightHolder">
			    					
					    				
					    				Just Super / Getty Images
				    				
		
					    			
					    				
					    				
					    				
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
					    				
					    				
										
									
							
								</span>
			    			
							
			    		</figcaption>
					</figure>
					
		
				
				
			
		</div>
	











	
	
	
		
	



<section class="epo cat-narrow" id="drr-top-ad">
	
		
		
				
   	
   	
   	
   		
   			
   		











<!-- Related -->









 <!-- Temporarily turn off "More like this" module and replace with ZipRecruiter -->


	<div class="related-promo-wrapper">
		<div class="sector apart">
			<div class="hed">More like this</div>
	    	<ul class="">
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3334858/microsoft/for-windows-7-users-the-glory-days-of-microsoft-are-ending-in-about-a-year.html"><img  class="small.3x2Image  imgId100751947 " src="https://images.idgesg.net/images/article/2018/03/binary_code_added_to_microsoft_windows_operating_system_on_nokia_lumia_mobile_phone_dennis_buntrock_cc0_via_pixabay-100751947-small.3x2.jpg" alt="Binary code surrounds a Nokia Lumia mobile phone running Microsoft Windows" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3334858/microsoft/for-windows-7-users-the-glory-days-of-microsoft-are-ending-in-about-a-year.html">For Windows 7 users, the glory days of Microsoft are ending in about a year</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/3311868/windows/how-to-manage-windows-10-updates.html"><img  class="small.3x2Image  imgId100725231 " src="https://images.idgesg.net/images/article/2017/06/windows10primary-100725231-small.3x2.jpg" alt="windows10primary" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/3311868/windows/how-to-manage-windows-10-updates.html">How to manage Windows 10 updates to prevent them from ruining your life</a></div>
	</div>
</li>
		    	
		    		
						
						
					














<li class="clearfix with-image">
	
		
		<a  href="/article/2875600/windows/windows-10-the-best-tips-tricks-and-tweaks.html"><img  class="small.3x2Image  imgId100739637 " src="https://images.idgesg.net/images/article/2017/10/windows-10-surface-laptop-100739637-small.3x2.jpg" alt="windows 10 surface laptop" itemprop="image" /></a>
    
	<div class="item">
		
		<div class="title"><a  href="/article/2875600/windows/windows-10-the-best-tips-tricks-and-tweaks.html">Windows 10: The best tricks, tips, and tweaks</a></div>
	</div>
</li>
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						




























































	
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
						
						
							
						
					














<li class="clearfix with-image">
	
		<a  class="play" href="/video/92067/6-ways-modern-laptops-make-life-more-convenient"><i class="ss-play"></i></a>
		<a  href="/video/92067/6-ways-modern-laptops-make-life-more-convenient"><img  class="small.3x2Image  imgId100780505 " src="https://images.idgesg.net/images/article/2018/11/mmm18_001_v1.00_00_54_15.still001-100780505-small.3x2.jpg" alt="Surface Laptop" itemprop="image" /></a>
    
	<div class="item">
		<div class="item-eyebrow">Video</div>
		<div class="title"><a  href="/video/92067/6-ways-modern-laptops-make-life-more-convenient">6 ways modern laptops make life more convenient</a></div>
	</div>
</li>
				
				
			
		
	




					
				
		    </ul>
		</div>
	</div>



   	


				<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
		
	

	
		











<!-- Related -->


 
	

</section>













		<section class="bodee">

			
				
				
					



















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	







	<div class="ad placement">
		
			
		





















	

		
			
			
				<!--  Begin gpt-skin/inread -->
				<div id="inread" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("inread", "true");
					IDG.GPT.displayGoogleTagSlot('inread');
				});
				</script>
				<!--  End gpt-skin/inread -->	
			
			
			
			
		
	
 	
 
 
	</div>








	
	
		
		
		<script>
			var dataLayer = window.dataLayer = window.dataLayer || [];
			dataLayer.push({
				'event': 'loadTopCollectionModule'
				});
		</script>
		
	


















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		


	
		<script>
			function gatherPerformanceMarks() {
				p = performance.getEntriesByType("mark");
				gtmEvent = {'event': 'gatherPerformanceMarks'};
			  	for (var i=0; i < p.length; i++) {
				    //console.log ("+++Mark only entry[" + i + "]: name = " + p[i].name + "; startTime = " + p[i].startTime);
				    gtmEvent[p[i].name] = p[i].startTime;
				  }
			  	var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push(gtmEvent);
			}
		  </script>
		

		












	
	



<script type="text/javascript">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</script>






	
	
		
	





	
		
			
			
			
				
			
			
		
	
	


	
	
		<div id="drr-container" class='cat ' itemprop="articleBody">
	
	
	
	

	<p>Windows users still running Windows 7 already face a deadline of Jan. 14, 2020, when Windows 7 support expires. But if you routinely block updates, break that habit briefly to allow an upcoming March patch. Otherwise, Windows 7 support will effectively stop in July.</p><p>Here’s what’s going on: Microsoft delivers updates using either the SHA-1 or SHA-2 encryption algorithm for security’s sake. But the company recently decided to phase out support for SHA-1 entirely<a href="https://support.microsoft.com/en-us/help/4472027/2019-sha-2-code-signing-support-requirement-for-windows-and-wsus" rel="nofollow"> in an upcoming security update</a>, due to begin delivery on March 12. That update will mark Windows’ shift to using the more secure SHA-2 hash algorithm. In July, Microsoft will begin delivering Windows 7 security updates using SHA-2. The upshot: if your Windows 7 PC hasn’t installed the March 12 update enabling SHA-2 support by July 16, your Windows updates will effectively end.</p><p>(Microsoft hasn’t released a name yet for the patch in question, but the solution is a simple one: Make sure Windows updates are enabled.)</p><aside id="fsb-2072" class="fakesidebar fakesidebar-auto"><a href="https://www.pcworld.com/article/2875600/windows/windows-10-the-best-tips-tricks-and-tweaks.html">[ Further reading: Our best Windows 10 tricks, tips and tweaks ]</a></aside><p>If you’re running Windows 10, don’t worry: Microsoft says its Windows 10 updates (for version 1709, 1803, and 1809, covering the most recent feature updates) are dual-signed with both SHA-1 and SHA-2. In June, those updates will shift to SHA-2 only—but you won’t need to do anything. The updates will shift hashing algorithms automatically, with no changes necessary on your part.</p><p>Microsoft has its own timeline for business users running WSUS: Apply the update Microsoft will deliver on March 12 by June 18. </p><p><strong>What this means to you:</strong> About 40 percent of the world’s PCs still run Windows 7, <a href="https://www.netmarketshare.com/operating-system-market-share.aspx?options=%7B%22filter%22%3A%7B%22%24and%22%3A%5B%7B%22deviceType%22%3A%7B%22%24in%22%3A%5B%22Desktop%2Flaptop%22%5D%7D%7D%5D%7D%2C%22dateLabel%22%3A%22Trend%22%2C%22attributes%22%3A%22share%22%2C%22group%22%3A%22platformVersion%22%2C%22sort%22%3A%7B%22share%22%3A-1%7D%2C%22id%22%3A%22platformsDesktopVersions%22%2C%22dateInterval%22%3A%22Monthly%22%2C%22dateStart%22%3A%222018-02%22%2C%22dateEnd%22%3A%222019-01%22%2C%22segments%22%3A%22-1000%22%7D" rel="nofollow">according to NetMarketshare</a>, meaning that millions of users will run out of time by the beginning of next year. But if you’re someone who loves the Windows 7 environment (hey, we don’t judge) you’ll want to make sure that Windows updates are enabled—otherwise, that deadline will arrive sooner than you think. </p>

	
	
		
	
	
	
	
		
		
		
		










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2008 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2008  blox4_html  blxC24068">To comment on this article and other PCWorld content, visit our <a href="https://www.facebook.com/PCWorld/" target="_blank">Facebook</a> page or our <a href="https://twitter.com/pcworld" target="_blank">Twitter</a> feed.  </div>
		
	

	


</div>
	
	
</div>

	<script>
		try {
			performance.mark("mark_article_body_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
	</script>





<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	
	
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>






    <div class="apart-alt tags">
    <span class="related">Related: </span>
    <ul>
		
			<li><a href="/category/windows">Windows</a></li>
		
			<li><a href="/category/microsoft">Microsoft</a></li>
		
			<li><a href="/category/security">Security</a></li>
		
			<li><a href="/category/business">Business</a></li>
		 
		
			
			
				 
					 
			    	
			    		<li><a href="/tag/windows7/" rel="nofollow">Windows 7</a></li>
			    				
				
			
				
		
    </ul>
   
	</div>









		
   		
		












		
	
	
	
	<div class="byline vcard author end-byline">	
		<div class="author-info" id="markhachman">		
			
			
				<p>As PCWorld's senior editor, Mark focuses on Microsoft news and chip technology, among other beats. </p>
					
		</div><!-- end .author-info -->	
		
		<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Mark-Hachman/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
					<li>
						<a href="https://twitter.com/markhachman" class="twitter-follow" target="_blank">
							<i class="ss-icon ss-social ss-twitter"></i>
						</a>
					</li>
					
					
					
				</ul>
			</div>
			
	</div>
	
	
		
		
		







	
	


















 




	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20190219115147"></script>


					










				
			
		
		</section><!-- /.bodee -->

		















		
			
				















<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="PCWorld_1"></div>  
	<script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>
</div>


			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=54ab7a69-a67d-4f7f-8f8c-cef18fa3f42f">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	


		</article>

	</section><!-- /role=main -->

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20190219115147" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,6);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Today's Special Offers</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					html += "<span>"+selectedAds[i].body+"</span>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20190219115147" />
<link rel="stylesheet" href="/www.idgcsmb.pcw/css/footer.css?v=20190219115147" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="http://pcworld.com" id="footer-logo-pcw" class="ir">PCWorld</a>
    		<p>PCWorld helps you navigate the PC ecosystem to find the products you want and the advice you need to get the job done.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="/faq" rel="nofollow">Digital Magazine</a></li>
				<li><a href="https://ssl.palmcoastd.com/31402/apps/PCWDIGITALGIFT?ikey=I**GF2">Gift Subscription</a></li>
				<li><a href="https://www.idg.com/about-adchoices-pcworld/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://shop.pcworld.com">Shop</a></li>
				<li><a href="/couponcodes">Coupon Codes</a>
					<ul>
						<li><a href="/couponcodes/aliexpress">Aliexpress</a></li>
						<li><a href="/couponcodes/ebay">Ebay</a></li>
						<li><a href="/couponcodes/home-depot">Home Depot</a></li>
						<li><a href="/couponcodes/hp">HP</a></li>
						<li><a href="/couponcodes/jcpenney">jcpenney</a></li>
						<li><a href="/couponcodes/oneplus">OnePlus</a></li>
						<li><a href="/couponcodes/walmart">Walmart</a></li>
						<li><a href="/couponcodes/target">Target</a></li>
						<li><a href="/couponcodes/6pm-com">6PM</a></li>
					</ul>
				</li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>			
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>PCWorld Categories</h2>
    		<ul>
    			<li><a href="/category/business/">Business</a></li>
				
				<li><a href="/category/laptop-computers/">Laptops</a></li>
				<li><a href="/category/mobile/">Mobile</a></li>
				<li><a href="/category/computers-all/">PC Hardware</a></li>
				
				<li><a href="/deals">Deals</a></li>
			</ul>
			<ul class="right">
				<li><a href="/category/printers/">Printers</a></li>
				<li><a href="/category/security/">Security</a></li>
				<li><a href="/category/software/">Software</a></li>
				<li><a href="/video/">Videos</a></li>
				<li><a href="/category/windows/">Windows</a></li>
			</ul>

			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="https://www.idg.com/advertise-with-us/pcworld/" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
				<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<div id="footer-subscribe" class="clearfix">
	    		<a href="https://ssl.palmcoastd.com/31402/apps/PCWDIGITAL?ikey=I**A02">
	    			<img src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png" alt="PCWorld Magazine Cover">
	    			<h2>Get PCWorld's Digital Editions</h2>
	    			<span class="btn-link">Subscribe Now</span>
	    		</a>
    		</div>
    		<div id="footer-social">
    			<span>Follow us</span> <a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					
						<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
							&#xF630;
						</a>
					 			    			
    		</div>
    		
    		 <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
		                
		                	
		                













	
		<option value="https://www.cio.com">CIO</option>
	
		<option value="https://www.cio-asia.com">CIO Asia</option>
	
		<option value="https://www.computerworld.com">Computerworld</option>
	
		<option value="https://www.csoonline.com">CSO</option>
	
		<option value="https://www.gamestar.com">Gamestar</option>
	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.idgconnect.com">IDG Connect</option>
	
		<option value="https://www.idg.tv">IDG.tv</option>
	
		<option value="https://www.infoworld.com">InfoWorld</option>
	
		<option value="https://www.itnews.com">IT News</option>
	
		<option value="https://www.itworld.com">ITworld</option>
	
		<option value="https://www.javaworld.com">JavaWorld</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.networkworld.com">Network World</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	
		<option value="https://www.thefullnerd.com/">The Full Nerd</option>
	

		            </select>
		    </div>
		    
		    <div class="copyright">
		    	<img src="https://alt.idgesg.net/images/logos/logo-footer-white.png" alt="IDG Communications" />
				<p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2019 IDG Communications, Inc.</small></p>		    
			</div>
    	</div>
    </div> 
</footer>
 


		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		












<script src="/www/js/analytics/mouse_down.js"></script> 



<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


	<script>
		$(document).ready(function() {
			if (typeof $.cookie("geoPromoDontShow") === 'undefined' && typeof $.cookie("geoPromoSeen") === 'undefined' && navigator.languages.indexOf("es") > -1 && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)) {
				$.get("/napi/tile?def=international.promo", 
					function(data) {
						$("body").prepend(data);
						var visitTime = new Date();
						visitTime.setTime(visitTime.getTime()+1000*60*60*24); //24 hours
				      	$.cookie('geoPromoSeen', 'true', { expires: visitTime, path: '/' });
						$(".geo-promo .ss-delete, a.cont-here, a.dont-show").click(function(e) {
							e.preventDefault();
							if ($(this).is(".dont-show")) {
								visitTime.setTime(visitTime.getTime()+1000*60*60*24*30); //30 days
						      	$.cookie('geoPromoDontShow', 'true', { expires: visitTime, path: '/' });
							}
							$(".geo-promo").fadeOut(function() {$(".geo-promo").remove()})
						});
					}
				);
			}
		});
	</script>

<script src="/www.idgcsmb/js/thm_post.js?v=20190219115147"></script>

<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>









<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script>
$(function() {
    $("img.lazy").lazyload({ 
    	effect : "fadeIn", 
    	threshold: 200,
    	failure_limit:25
    });
});
</script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>




	<!-- LiveRamp Sources -->
	<script type="text/javascript"src="//storage.googleapis.com/cdn.pippio.com/sdk/pippio.min.js" async></script>
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	
	$(document).ready(function(){

		$('#extra-nav-toggle a').click(function(){
			if($(this).hasClass('open')){
				$('#extra-nav').hide();
				$(this).removeClass('open');
				$('#extra-nav-toggle a').removeClass('ss-delete');
				$('#extra-nav-toggle a').addClass('ss-dropdown');		
			} else {
				$('#extra-nav').show();
				$(this).addClass('open');
				$('#extra-nav-toggle a').removeClass('ss-dropdown');
				$('#extra-nav-toggle a').addClass('ss-delete');					
			}
			return false;
		});
		
		var isMobile = window.matchMedia("only screen and (min-width: 60.625em)");

    	if (isMobile.matches) {	
    		
			$('li.dealsNav').mouseenter(function(){
			    $(".dealsList").css({ 'display':'block'});
			});           
		
			$('ul.dealsList').mouseleave(function(){  
			    $(".dealsList").css({ 'display':'none'});	    
			});
		
		}
		  				  
	});//-- end document Ready
		
	


	g_bRequireHttps = true;
	 
		$.ajax('/ads/tso',{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	





<!-- Begin BlueKai Tag-->
<iframe name="__bkframe" height="0" width="0" frameborder="0" src="javascript:void(0)"></iframe>
<script type="text/javascript" src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<!-- CryptoJS -->
<script src="/www/js/utils/md5.js"></script>
<script type="text/javascript" src="/www/js/analytics/idg_bk_coreapi.js"></script>

<script type="text/javascript">
bk_allow_multiple_calls=true;
var blueKaiId=13979;
var blueKaiPort=10;
var brandCode = "pcw";
var regUrl="https://regdev.idge.int/api/"
var daysToRefresh=30;
var bk_debug_log=false;


regUrl="https://reg.idgenterprise.com/api/";



daysToRefresh=30;


	




//CMS-Specific
bk_addPageCtx("cmscatids", "[3034,3404,2206,4846]");



	bk_addPageCtx("goldenIds", "[226,804,941,1177]");


bk_addPageCtx("cmpy", "[]");

bk_addPageCtx('tid', '2');

	










try{
	consent.adsel.queue.push(function(){
		console.log('*****GDPR: running queue for bluekai ad selection');
		IDG.bkCoreApi.start();
	});
}
catch(e){
	//alert("Triggering catch")
	consent.adsel.queue.push(function(){
		bk_doJSTag(blueKaiId ,blueKaiPort);
	});
	if (window.console && window.console.log){
		window.console.log("Error Occured While Processing Profile Siubmission")
	}
}



//bk_doJSTag(13979, 10);











$('article, #slideshowCarousel').on('click', '.product-list-price, .btn-amazon, .productLink', function(e) {
	var $linkEl = $(e.target);
	var po = $linkEl.data('po');
	if ($.inArray(po, ['amazon', 'vendor', 'other']) >= 0) {
		if (po == 'amazon') {
			var prCat = $linkEl.data('bkc');
			if (typeof prCat != 'undefined') {
				bk_addPageCtx('event', 'AmazonClick'+prCat);
			}
			
			bk_addPageCtx('event', 'AmazonClickWindows');
			
			bk_addPageCtx('event', 'AmazonClickMicrosoft');
			
			bk_addPageCtx('event', 'AmazonClickSecurity');
			
			bk_addPageCtx('event', 'AmazonClickBusiness');
			
		}
		var prMfr = $linkEl.data('bkmfr');
		if (typeof prMfr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceMFR'+prMfr);
		}
		var prVndr = $linkEl.data('bkvndr');
		if (typeof prVndr != 'undefined') {
			bk_addPageCtx('event', 'eCommerceClickVendor'+prVndr);
		}
		consent.adsel.queue.push(function(){
			bk_doJSTag(34202, 1);
		});
	}
});
</script>
<!-- End BlueKai Tag -->

 		
		










<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"pcw","e":"view","t":"article","id":"3341800"});
	
});
</script>
	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20190219115147  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
			
	</body>
</html>
