










<!DOCTYPE html>


	
	
		
	
		
	
	
	
	

<html lang="en">
	












<head>
	<link rel="alternate" hreflang="en" href="https://www.pcworld.com/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html" />	
	<meta charset="utf-8" />
	<title>The best alternatives to Amazon for buying tech right now | PCWorld</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0" />
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
	
	<!-- ad-related js -->
	
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js"></script>
	
	











<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>

<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.blueconic = consent.blueconic || {};
consent.blueconic.queue = consent.blueconic.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>






<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.pcworld.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});
</script>

<script src="/www/js/messaging.js?v=dec2019update"></script>


<script type="text/javascript">(function () { var e = false; var c = window; var t = document; function r() { if (!c.frames["__uspapiLocator"]) { if (t.body) { var a = t.body; var e = t.createElement("iframe"); e.style.cssText = "display:none"; e.name = "__uspapiLocator"; a.appendChild(e) } else { setTimeout(r, 5) } } } r(); function p() { var a = arguments; __uspapi.a = __uspapi.a || []; if (!a.length) { return __uspapi.a } else if (a[0] === "ping") { a[2]({ gdprAppliesGlobally: e, cmpLoaded: false }, true) } else { __uspapi.a.push([].slice.apply(a)) } } function l(t) { var r = typeof t.data === "string"; try { var a = r ? JSON.parse(t.data) : t.data; if (a.__cmpCall) { var n = a.__cmpCall; c.__uspapi(n.command, n.parameter, function (a, e) { var c = { __cmpReturn: { returnValue: a, success: e, callId: n.callId } }; t.source.postMessage(r ? JSON.stringify(c) : c, "*") }) } } catch (a) { } } if (typeof __uspapi !== "function") { c.__uspapi = p; __uspapi.msgHandler = l; c.addEventListener("message", l, false) } })();</script>
<script>
        window._sp_ccpa = {
            config: {
                mmsDomain: "https://cmp.pcworld.com",
                ccpaOrigin: "https://ccpa-service.sp-prod.net",
                accountId: "146",
                getDnsMsgMms: true,
                alwaysDisplayDns: false,
            }
        }
</script>
<script src="https://ccpa.sp-prod.net/ccpa.js"></script>

<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		
		consent.personalization=false;
		
		__uspapi('getUSPData', 1, (uspData, success) => {
			if(success) {
				try {
					console.log('uspapi success: ', uspData);
					var uspDataString = uspData.uspString;
					var uspDataArray = [];
					uspDataArray = uspDataString.split("");
					if (typeof uspDataArray[2] !== "undefined" && uspDataArray[2] !== "Y") {
						console.log('User has not opted in to CCPA - run everything');
						consent.personalization=true;
						$(window).trigger("runConsent", [consent.socmedia.queue]);
						$(window).trigger("runConsent", [consent.blueconic.queue]);
					}
		
					$(window).trigger("runConsent", [consent.adsel.queue]);
				}
				catch(e) {
					console.log('error with uspData retrieval: ', e);
				}
				
			} else {
				console.log('uspapi fail: ', uspData);
			}
			
		});	
		
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		
	
		dataLayer.push({
			'event': 'consentKnown' 
		});
		bindReshowCmp();
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for blueconic
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.blueconic.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3934, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
		











<script>
consent.blueconic.queue.push(function(){
	var bcscript = document.createElement("script");
	bcscript.async = true;
	bcscript.type = "text/javascript";
    var useSSL = "https:" == document.location.protocol;
    bcscript.src = (useSSL ? "https:" : "http:") + "//cdn.blueconic.net/idg.js";
    var node=document.getElementsByTagName("script")[0];
    node.parentNode.insertBefore(bcscript, node);
});
</script>
	
	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "pcw";
let brandConfigBrandId = "2";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/pcworld";
var linkedInUrl = "";
var facebookUrl = "http://www.facebook.com/PCWorld";
var youTubeUrl = "";
var twitterHandle = "pcworld";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}
if (countryCode === 'au') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'nz') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'nl') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "";
//cookie policy page
var localeEdition = "";
var busUnitAddress = "";
if (countryCode === 'asean') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'in') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'au') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'nz') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'nl') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	

	
    <script src="/www/js/init_device.js"></script>    
    
    	
    
    
   	
   	
		
			






















	<script async src="//js-sec.indexww.com/ht/p/183980-214854100715128.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20200402114305"></script>


	












<script>

function refreshCountdown(slotName) {
	IDG.GPT.log(slotName + " refresh countdown: " + IDG.GPT.refreshCountdown[slotName].timeRemaining);
	IDG.GPT.refreshCountdown[slotName].timeRemaining -= 1;
	
	if (IDG.GPT.refreshCountdown[slotName].timeRemaining == 0) {
		clearInterval(IDG.GPT.refreshCountdown[slotName].interval);
		IDG.GPT.log(slotName + ' - time to refresh ad!');
		
		//perform ad refresh
		IDG.GPT.refreshAd(slotName);		
	}
}

var refreshInterval = 30;

var testRefreshInterval = IDG.GPT.getUrlParameter("interval");
if (typeof testRefreshInterval !== "undefined" && typeof parseInt(testRefreshInterval) === "number") {
	refreshInterval = parseInt(testRefreshInterval);
}

IDG.GPT.log("Ad refreshing ON - every " + refreshInterval + " seconds");

IDG.GPT.viewable = {};
IDG.GPT.visibility = {};
IDG.GPT.refreshCountdown = {};

IDG.GPT.impressionViewable = function (){
	googletag.pubads().addEventListener('impressionViewable', function (event) {
		var currentSlot = event.slot.getSlotElementId();
		if (currentSlot !== 'inread' && currentSlot !== 'gpt-skin' && currentSlot !== 'gpt-superstitial' && currentSlot !== 'gpt-overlay' ) {
			IDG.GPT.viewable[currentSlot] = true;
			IDG.GPT.log("The ad in " + currentSlot + " counts as a viewable impression.");
			
			IDG.GPT.refreshCountdown[currentSlot] = {};
			//if slot visibility > 50, start countdown timer
			if (IDG.GPT.visibility[currentSlot] >= 50) {
				IDG.GPT.refreshCountdown[currentSlot].timeRemaining = refreshInterval;
				IDG.GPT.refreshCountdown[currentSlot].interval = setInterval(function(){
					refreshCountdown(currentSlot);
				}, 1000)			
				IDG.GPT.log('Impression viewable - starting countdown for ' + currentSlot);
			}
		}
	});
};



IDG.GPT.visibilityChanged = function() {
	googletag.pubads().addEventListener('slotVisibilityChanged', function (event) {
		var currentSlot = event.slot.getSlotElementId();
		var currentVisibility = event.inViewPercentage;
		
		if (currentSlot !== 'inread' && currentSlot !== 'gpt-skin' && currentSlot !== 'gpt-superstitial' && currentSlot !== 'gpt-overlay' ) {
			if (typeof IDG.GPT.visibility[currentSlot] !== "undefined") {
				//if this slot has a viewable impression...
				if (typeof IDG.GPT.viewable[currentSlot] === "boolean" && IDG.GPT.viewable[currentSlot] == true) {
					//if stored value < 50 and current value >=50, start countdown timer
					if (IDG.GPT.visibility[currentSlot] < 50 && currentVisibility >= 50) {
						IDG.GPT.refreshCountdown[currentSlot].timeRemaining = refreshInterval;
						IDG.GPT.refreshCountdown[currentSlot].interval = setInterval(function(){
							refreshCountdown(currentSlot);
						}, 1000)
						IDG.GPT.log('Came into view - restarting countdown for ' + currentSlot);
					}
					//else if stored value >= 50 and current value < 50, stop countdown timer (if exists)
					else if (IDG.GPT.visibility[currentSlot] >= 50 && currentVisibility < 50) {
						clearInterval(IDG.GPT.refreshCountdown[currentSlot].interval);
						IDG.GPT.log('Went out of view - stopping countdown for ' + currentSlot);
					}
				}
				//update visibility
				IDG.GPT.visibility[currentSlot] = currentVisibility;
			}
			else {
				//set initial visibility
				IDG.GPT.visibility[currentSlot] = currentVisibility;
			}
			
			IDG.GPT.log(currentSlot + " visibility: " + currentVisibility);
		}
	});
};

IDG.GPT.googleCommandPush(IDG.GPT.impressionViewable);
IDG.GPT.googleCommandPush(IDG.GPT.visibilityChanged);



</script>


<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.US_CSMB_PCWorld.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "consumer-electronics_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/computers');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'laptop-computers');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3535569');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'feature');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '6');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'dell');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3015','4064','3799']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['laptop-computers','amazon-com','consumer-electronics']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['350','736','1025']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Mark Hachman');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
	
</script>
  
<script src="/www.idgcsmb/js/thm_pre.js?v=20200402114305"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
			
			//IDGMPM-18418 - capture paermutive key-values
			window.headertag = window.headertag || {};
			window.headertag.cmd = window.headertag.cmd || [];
			window.headertag.cmd.push(function() {
				try {
					var segs = JSON.parse(localStorage._pdfps || '[]').slice(0,250);
					window.headertag.setUserKeyValueData({ segments: {"permutive": segs} });                
				} catch (e) {}
			});
			
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	

	
		<script type="text/javascript" src="/www/js/ads/gpt_launcher.js"></script>
		<script>$(window).trigger("runConsent", [IDG.GPT.displayQueue]);</script>
	



		
		
	

	

    <link rel="canonical" href="https://www.pcworld.com/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html" />
	
	
	
	
	
	<meta name="description" content="Here are the best places to shop for home office technology besides Amazon. We&#039;ll tell you what&#039;s in stock, what&#039;s not, and the overall convenience of these alternatives to Amazon." />
	<meta itemprop="image" content="https://images.idgesg.net/images/article/2020/04/14510163182_a60e2bf65a_o-100837411-medium.jpg">
	
	
		
			<meta name="DC.date.issued" content="2020-04-03" />
			<meta name="date" content="2020-04-03" />
			
		
		
		
		 
	
	
	<link rel="amphtml" href="https://www.pcworld.com/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.amp.html" />

	
		<link rel="stylesheet" href="https://use.typekit.net/ehr0jod.css" />
	
	
	<meta property="twitter:account_id" content="6070762" />
	<meta property="fb:app_id" content="1542125639335283" />
	
		
		
		
			
			
				
			
			
			
		
		
	<meta property="og:type" content="article">	
	<meta property="og:url" content="https://www.pcworld.com/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html">
    <meta property="og:site_name" content="PCWorld">   
    
    
    	<meta property="og:image" content="https://images.idgesg.net/images/article/2020/04/14510163182_a60e2bf65a_o-100837411-large.3x2.jpg">
    	<meta property="og:image:width" content="1200">
    	<meta property="og:image:height" content="800">
    
    
    
    
    
    
    	<meta property="og:title" content="The best alternatives to Amazon for buying tech right now"> 
    
    
    <meta property="og:description" content="Here are the best places to shop for home office technology besides Amazon. We&#039;ll tell you what&#039;s in stock, what&#039;s not, and the overall convenience of these alternatives to Amazon.">
    
    
		<meta property="fb:pages" content="7352931005" />
	

	
	<meta name="displaytype" content="article" />
	
	<meta name="source" content="pcworld" />
	
	<meta name="category" content="laptops,amazon.com,consumer electronics" />
	
	<meta name="storytype" content="feature" />
	
	
	
		<meta name="google-site-verification" content="FjWdymWSdutZJ-XIYfqJXlQZbLR7hMWmkwR5MQ0yqeY" />
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header-mobile.css?v=20200402114305" />
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idgcsmb/css/inline-header.css?v=20200402114305" />');
			}
		</script>
		<link rel="stylesheet" href="/www.idgcsmb.pcw/css/inline-header.css?v=20200402114305" />
	 
	
	
	    
	
	<link rel="stylesheet" href="/www.idgcsmb/css/print.css" media="print" />
	
	<!-- this must be first -->
	<link href="/www.idgcsmb/css/colorbox.css" rel="stylesheet" />
	<!-- <link href="/www.idgcsmb/css/equalizer.css" rel="stylesheet" /> -->
	<link href="/www.idgcsmb/css/global-layout.css?v=20200402114305" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-layout.css?v=20200402114305" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-colors.css?v=20200402114305" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-colors.css?v=20200402114305" rel="stylesheet" />
	<link href="/www.idgcsmb/css/global-typography.css?v=20200402114305" rel="stylesheet" />
	<link href="/www.idgcsmb.pcw/css/global-typography.css?v=20200402114305" rel="stylesheet" />
	
	
	
	
		
		
			
			
				<link rel="stylesheet" href="/www/css/article.css?v=20200402114305" />	
			
			
		<link href="/www.idgcsmb.pcw/css/article.css?v=20200402114305" rel="stylesheet" />
	
	
	<link href="/www.idgcsmb/css/video.player.css?v=20200402114305" rel="stylesheet" media="all" />

	
	
	
	
	
	
	
	
	
	
	
	
	  
	<!-- this must be last -->
	<link href="/www.idgcsmb/css/helpers.css" rel="stylesheet" />
	
	
		<script>
		try {
			performance.mark("mark_head_css_done_blocking");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" href="/www.idgcsmb.pcw/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="129x129" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-129.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed-72.png" />
	<link rel="apple-touch-icon" href="https://csmb.staticworld.net/images/furniture/pcworld/pcw-apple-touch-icon-precomposed.png" />
	

	
		
	
	
	
	
	<script type="text/javascript">
	var _sf_async_config={};
	_sf_async_config.uid = 29363;
	
	
	
		_sf_async_config.useCanonical = true;
	
	
	
		
						
	_sf_async_config.authors="Mark Hachman";
			
		
			
			
	_sf_async_config.sections="computers";	
		
		
		
		
	_sf_async_config.domain = "pcworld.com";
	</script>
	
	
	
	
	
	<!-- <link href="/www.idgcsmb/webfonts/ss-social.css" rel="stylesheet" />
	<link href="/www.idgcsmb/webfonts/ss-standard.css" rel="stylesheet" />  -->
	<!--[if lte IE 8]>  
		<link href="/www.idgcsmb/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]-->


	
	<!-- Use Twitter Summary Card with Large Image for articles and videos; summary otherwise -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	
	<meta property="twitter:description" content="Here are the best places to shop for home office technology besides Amazon. We&#039;ll tell you what&#039;s in stock, what&#039;s not, and the overall convenience of these alternatives to Amazon.">
	
	
		
			<meta name="twitter:site" content="@pcworld">
			
			
				
					<meta name="twitter:image" content="https://images.idgesg.net/images/article/2020/04/14510163182_a60e2bf65a_o-100837411-orig.jpg" />
				
				
						
			
				
				
					<meta name="twitter:title" content="The best alternatives to Amazon for buying tech right now">
				
				
			
			
				
				
					<meta name="twitter:url" content="www.pcworld.com">
				
			
		
		
		
		
		
	
	












<script type="application/ld+json">
	{
		"@context": "http://schema.org",
		"@type": "WebSite",
		"url": "https://www.pcworld.com/",
		"potentialAction": {
		"@type": "SearchAction",
		"target": "https://www.pcworld.com/search?query={search_term}",
		"query-input": "required name=search_term"
		}
	}
</script>
	
	
	
	
	<script src="/www/js/ads/ad.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	
	
	
	
		
			
				
			
			
			
			
			
			
		
		
		
	
	
	
		
		
		
		
		  
		
	
	
	
	
	
	
	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
		
		
		
	
	
	<script>
	var supMontMods = false;
	</script>
	


	
	
			
			
			
			
				
					
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		
















	


			
	
	
	
	
	




	
		
	
		
	
	



	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	 
	 
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	 
	 
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
		
	
	
	<script>
	var idg_uuid = $.cookie('idg_uuid') || "";
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined') {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode;
	}

	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	dataLayer.push({
		'ancestorGoldenCategories': '',
		'articleId': '3535569',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': '',
		'articleTitle': 'The best alternatives to Amazon for buying tech right now',
		'articleType': 'Feature',
		'audience':'consumer',
		'author':'Mark Hachman',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdAll': '3015, 4064, 3799',
		'categoryIdList':'3015,4064,3799',
		'categoryIdPrimary': '3015',
		'contentStrategy': '',
		'contentType':'feature',
		'datePublished':'2020-04-03',
		'dateUpdated':'2020-04-03',
		'daysSincePublished':'0',
		'daysSinceUpdated':'0',
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-739745-1',
		'geolocEnabled':'true',
		'goldenTaxonomyIdAll': '347, 736, 1025',
		'goldenTaxonomyIdList': '736,1025',
		'goldenTaxonomyIdPrimary': '347',
		'isBlog':'false',
		'isInsiderContent':'',
		'isICN': 'false',
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'pcs',
		'primaryCategoryAll': 'pcs, amazon.com, consumer electronics',
		'primaryCategoryList': 'amazon.com,consumer electronics',
		'primaryAncestorCategoryList': '',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'property': 'pcworld',
		'propertyCountry':'US',
		'purchaseIntent':'',
		'skimlinksId':'111346X1569483',
		'source':'pcworld',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>
	 
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	//look for variable set in ad.js
	if (window.canRunAds === undefined) {
		adBlockStatus = 'true';
	} else {
		adBlockStatus = 'false';
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
		<script>
			try {
				performance.mark("mark_head_js_done_blocking");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");

			}
		</script>
	
	
	
	
		<script>
			function bindPerformanceMarks(){
			//even though it's called slotRenderEnded, it's the first thing to happen -  corresponds to when we get a response back from DFP
			googletag.pubads().addEventListener('slotRenderEnded', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial' && !event.isEmpty) {//also ensure it's not an empty ad response
					performance.mark("mark_welcome_render_begin");
				}
			});
			googletag.pubads().addEventListener('slotOnload', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_render_end");
				}
			});
			googletag.pubads().addEventListener('impressionViewable', function(event) {
				var slotId = event.slot.getSlotElementId();
				//console.log("slotId = "+slotId);
								
				if (slotId == 'gpt-superstitial') {
					performance.mark("mark_welcome_impression_viewable");
									
				}
			});
				}
				try {
					IDG.GPT.googleCommandPush(bindPerformanceMarks);
				}
				catch(e){
					console.log('error binding performance marks: ' + e);
				}
		</script>
	
	
	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	
	
	
	

	
		










<script>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</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	
	
	
	
</head>

	<body id="article3535569" class="article pcworld">
		 
		
			<div id="skinAdTarget"></div>
		

		
			<div id="superadunit" class="hidden">
			    <div class="ad">
			    	<div class="ad-header">
						<div class="brand-logo"></div>
						<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
					</div>
					
						
						
						
					




















	
		
		
		
		
			
		  		<script type="text/javascript">
		  		
		  		
				document.write('<div id="gpt-superstitial" class=" ad-container"></div>');
				consent.ads.queue.push(function(){
			  		try {			  			
			   			IDG.GPT.addDisplayedAd("gpt-superstitial", "true");
			   			$('#gpt-superstitial').responsiveAd({screenSize:'971 1115', scriptTags: []});
			   			IDG.GPT.log("Creating ad: gpt-superstitial [971 1115]");
			   		}
					catch (exception) {
						console.log("Error with IDG.GPT: " + exception);
					}
		  		});
				
				</script>
		
		
	
 
 
	
			    </div><!-- / ad -->
			</div><!-- / super -->		
		

		











	
	
		
		
		
		
		
			
		
				
					
				











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


		
		
		
		
		
		
		
		
		
		
		
		<div id="page-top">
				<div class="page-top-inner" itemscope itemtype="http://schema.org/Organization">
				<link itemprop="url" href="http://www.pcworld.com"> 
			    
		
		
		
		
		<div class="network-header">
				<div class="network-header-inner">
					<div id="network-tools">
		
						<div id="saved-comparisons"></div>				
						<ul class="hmenu" id="heroLogin">				
							<li class="subscribeHeader"><a href="https://simplecirc.com/subscribe/pcworld">Subscribe</a><div class="subscribe-hover" style="">
		                        <div class="pointer">&#9650;</div>
		                        <span>Learn more about PCWorld's Digital Editions</span>
		                        <img alt="PCWorld Magazine Cover" src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png">
		                      </div></li>
							
						</ul>
					</div><!-- /#network-tools -->
		
						<div id="network-social">					
		                  
							
							<a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
								&#xF610;
							</a>
							<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
								&#xF611;
							</a>
							<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
								&#xF630;
							</a>
		
						<form id="search-form" action="/search">
							<input type="search" name="query" id="banner-search-term" class="inactive searchbox-input-class" value="">
							<input type="submit" name="submit" id="banner-search-submit" value="search" />
							<a id="magGlassClick" class="ss-icon ss-standard" type="submit">&#x1F50E;</a>
						</form>
		
						</div><!-- /#network-social -->
					
						
				</div>
			</div><!-- /.network-header -->
		
		
			<header id="banner">
				<a id="mobile-offscreen-toggle" class="ss-standard ss-rows" href="javascript://"></a>
				<div id="logo">
					<a href="/" class="ir banner-logo" id="logoImage">Home</a>		
				</div>
				<div id="mobile-search-toggle" class="ss-standard ss-search"></div>
			</header>
		
		
			


















  <script>
	const currentYear = new Date().getFullYear();
	const blackFridayCoupons = '<li><a href="https://www.pcworld.com/couponcodes/campaigns/black-friday">Black Friday '+currentYear+' Coupons</a></li>';
	const cyberMondayCoupons = '<li><a href="https://www.pcworld.com/couponcodes/campaigns/cyber-monday">Cyber Monday '+currentYear+' Coupons</a></li>';	
	let couponLinks = '<li><a href="https://www.pcworld.com/couponcodes">All Coupon Codes</a></li>';
	
	fetch("/saving-united/top-shops")
	.then(response => response.text())
	.then(text => {
		const parser = new DOMParser();
	  	const htmlDocument = parser.parseFromString(text, "text/html");
	  	const section = htmlDocument.documentElement.querySelector("body");
	  	const shopsObj = JSON.parse(section.textContent);
	  
	  	for (let i = 0; i < shopsObj.length; i++) {
			let anchorText = shopsObj[i].anchor_text;
			let anchorTextURL = shopsObj[i].url;
			couponLinks = couponLinks + "<li><a href="+anchorTextURL+">"+anchorText+"</a></li>";
	  	}
	  
	  	couponLinks = couponLinks + blackFridayCoupons + cyberMondayCoupons;
	  	document.getElementById("couponChildren").innerHTML = couponLinks;
	}).catch(err => console.error(err));
  </script>
  <style>
  @media only screen and (max-width: 767px) and (min-width: 320px) {
  	  #page-top.open-nav {
  	    position: relative;
  	  }
	  .pcworld #panel-nav li.dealsNav ul.dealsList .couponCodes .couponChildLinks li {
	  	display: table;
	  	padding: 2px 0 !important;
	  }
	  .pcworld #panel-nav li.dealsNav ul.dealsList li {
	  	display: table;
    	padding: 10px 0 0px 3px !important;
	  }
  }
  </style>




<div id="main-nav">
	<div class="container clearfix">
		<ul class="fmenu" id="panel-nav">
			<li class="newsNav"><a href="/news/" id="whatsHotNav">News</a></li>
			<li class="reviewsNav"><a href="/reviews/" id="reviewsNav">Reviews</a></li>
			<li class="howtoNav"><a href="/howto/" id="howtoNav">How-To</a></li>
			<li class="videoNav"><a href="/video/" id="videoNav">Video</a></li>
			
			
				<li class="dealsNav"><a id="dealsNav">Deals <span class="ss-dropdown right"></span></a> 
					<ul class="dealsList">
						<li><a href="/deals" id="dealsNav">All Deals</a></li>
						<li class="couponCodes"><a class="couponCodeMob"><span>Coupon Codes</span><span class="rightArrow">&raquo;</span> </a>
							<ul id="couponChildren" class="couponChildLinks">						
							
							</ul>
						</li>
						<li><a href="https://shop.pcworld.com">Shop</a></li>
						<li><a href="https://software.pcworld.com">Software Store</a></li>
					</ul>
				</li>
			

		</ul>

		<ul class="fmenu" id="site-nav">
			
				<li><a href="/category/business/">Business</a>
					
				</li>
			
				<li><a href="/category/laptop-computers/">Laptops</a>
					
				</li>
			
				<li><a href="/category/smartphones/">Smartphones</a>
					
				</li>
			
				<li class="selected"><a href="/category/hardware/" class="active">Hardware</a>
				
					<ul>
						
								
									
									
										<li class="sub-selected"><a href="/category/computers/">PCs</a></li>
									
													
						
								
									
									
										<li><a href="/category/components-graphics/">Graphics Cards</a></li>
									
													
						
								
									
									
										<li><a href="/category/input-devices/">Input Devices</a></li>
									
													
						
								
									
									
										<li><a href="/category/displays/">Displays</a></li>
									
													
						
								
									
									
										<li><a href="/category/printers/">Printers</a></li>
									
													
						
								
									
									
										<li><a href="/category/storage/">Storage</a></li>
									
													
						
								
									
									
										<li><a href="/category/networking/">Networking</a></li>
									
													
						
								
									
									
										<li><a href="/category/cameras/">Cameras</a></li>
									
													
						
					</ul>
					
				</li>
			
				<li><a href="/category/security/">Security</a>
					
				</li>
			
				<li><a href="/category/software/">Software</a>
					
				</li>
			
				<li><a href="/category/gadgets/">Gadgets</a>
					
				</li>
			
			<li class="displayMobileOnly"><a href="/magazines">Subscribe</a></li>
			
		</ul>
		
			<div id="extra-nav-toggle"><a href="#extra-nav" class="ss-dropdown"></a></div>
			
			<div id="extra-nav">
				<ul>
					
						<li><a href="/resources/">Resources</a></li>
					
						<li><a href="/category/computers/">PCs</a></li>
					
						<li><a href="/category/smartphones/">Smartphones</a></li>
					
						<li><a href="/category/printers/">Printers</a></li>
					
						<li><a href="/category/ultrabooks/">Ultrabooks</a></li>
					
					<li><a href="/blogs">Blogs</a></li>
					<li><a href="/sponsors">Sponsorships</a></li>
				</ul>
				<ul>
					
						<li><a href="/category/antivirus-software/">Viruses</a></li>
					
						<li><a href="/category/cameras/">Cameras</a></li>
					
						<li><a href="/category/components/">Components</a></li>
					
						<li><a href="/category/computers-accessories/">Computer Accessories</a></li>
					
						<li><a href="/category/consumer-advice/">Consumer Advice</a></li>
					
						<li><a href="/category/digital-assistants/">Digital Assistants</a></li>
					
						<li><a href="/category/displays/">Displays</a></li>
					
						<li><a href="/category/e-readers/">E-readers</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/components-graphics/">Graphics Cards</a></li>
					
						<li><a href="/category/storage-drives/">Hard Drives</a></li>
					
						<li><a href="/category/home-theater/">Home Theater</a></li>
					
						<li><a href="/category/input-devices/">Input Devices</a></li>
					
						<li><a href="/category/input-keyboards/">Keyboards</a></li>
					
						<li><a href="/category/laptop-accessories/">Laptop Accessories</a></li>
					
						<li><a href="/category/mobile/">Mobile</a></li>
					
						<li><a href="/category/networking/">Networking</a></li>
					
				</ul>
				<ul>
					
						<li><a href="/category/operating-systems/">Operating Systems</a></li>
					
						<li><a href="/category/storage-optical/">Optical Drives</a></li>
					
						<li><a href="/category/cpu-processors/">CPUs</a></li>
					
						<li><a href="/category/servers/">Servers</a></li>
					
						<li><a href="/category/smartwatches/">Smartwatches</a></li>
					
						<li><a href="/category/streaming-services/">Streaming Services</a></li>
					
						<li><a href="/category/storage/">Storage</a></li>
					
						<li><a href="/category/tablets/">Tablets</a></li>
					
						<li><a href="/category/windows/">Windows</a></li>
					
				</ul>
			</div>
		
	</div>
</div>	<!--/#main-nav-->


<div id="section-nav">
		<div class="container clearfix">
			<ul class="fmenu">
				
					<li >
						
							
							
								<a href="/category/computers/" class="active">PCs</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/components-graphics/">Graphics Cards</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/input-devices/">Input Devices</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/displays/">Displays</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/printers/">Printers</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/storage/">Storage</a>
							
						
					</li>

				
					<li >
						
							
							
								<a href="/category/networking/">Networking</a>
							
						
					</li>

				
					<li style="display:none">
						
							
							
								<a href="/category/cameras/">Cameras</a>
							
						
					</li>

				
			</ul>
		</div>
</div><!--/#section-nav-->








		
		
				</div> 
			</div> 
		
		
		
		
					<!-- Events Header -->
				
					
						
						 
							
								
								
								
								
								
											    			
								
							
							
							
							
							
						
						 
						 
						 
						 
						  
						  
						 
						 
					











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


				
		
		
		<script>
		$(document).ready(function(){
			$('.searchbox-input-class').each(function(){
			    $(this).change(function(){
			    	var qStr=$(this).val();
			    	if($(this).val().indexOf('@')!=-1){
			    		qStr=qStr.replace(/@/g,' ');
			    		$(this).val(qStr);
			    	}
			    });
			});
		});
		</script>
	


		
		













<div id="page-wrapper" class="page-wrapper">
	
	










	
	<section role="main" itemscope itemtype="http://schema.org/Article">
	
		
		
		

		<article itemscope itemtype="http://schema.org/Article"  >

		











	
	





































<script src="/www/js/date-time-moments.js"></script>


	
	
		<script>
		// non-edition sites
		$(document).ready(function() {
			var fullDate = "2020-04-03T13:02-0700";
			var dateFormat = "MMM D, YYYY h:mm a z";
			timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // 12 hour format
			document.querySelector(".format-date").textContent = timeDate;
		});
		</script>
	



















	
			
















<header class='cat'>

	
	
	
	
	
	
		<!-- CSMB Horizontal Responsive -->
<ins class="adsbygoogle"
     style="display:block;"
     data-ad-client="ca-pub-4268075595326305"
     data-ad-slot="9945794902"
     data-ad-format="link"></ins>


<script>
consent.ads.queue.push(function(){
	$.getScript( "//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" )
		  .done(function( script, textStatus ) {
		    //need to add  && publisherConsents.gdprApplies back to the end of this conditional after testing
			  if (!consent.personalization && consent.isEU)  {
				   (adsbygoogle=window.adsbygoogle||[]).requestNonPersonalizedAds=1
				   console.log('*****GDPR: loaded adsense in non-personalized mode')
			  }
			  else {
			   		(adsbygoogle = window.adsbygoogle || []).push({});
			   	 	console.log('*****GDPR: loaded adsense in normal mode');
			  } 
		  })
		  .fail(function( jqxhr, settings, exception ) {
		    console.log( "Triggered ajaxError handler." );
		});
});
</script>
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
				
					<li><a class="edition-link-url" href="/category/laptop-computers/" itemprop="url"><span class="article-primary-cat" itemprop="title">Laptops</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
	
	
	
		
		
			<div class="category"><a class="edition-link-url" href="/feature" itemprop="genre">Feature</a></div>
		
	
	

	<h1 itemprop="headline">The best alternatives to Amazon for buying tech right now</h1>
	
		<script>
		try {
			performance.mark("mark_headline_rendered");
		}
		catch(e) {
			console.log("Error saving performance mark -- this function may not be supported in this browser");
		}
		</script>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">Specialty electronics stores like Newegg have availability, but retailers like Best Buy can get you what you want, fast—provided the item's in stock.</h3>
		</section>
	
	
	
	
	
	
	
	
			<div class="cat-social">
				
					
				















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">



	<li class="sosh">
		<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&via=pcworld&text=The+best+alternatives+to+Amazon+for+buying+tech+right+now" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>	
	</li>
	<li class="sosh">
		<a data-socialsite="Linkedin" href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&title=The+best+alternatives+to+Amazon+for+buying+tech+right+now" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>
	<li class="sosh">
		<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&title=The+best+alternatives+to+Amazon+for+buying+tech+right+now" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
		</a>
	</li>
	<li class="sosh cat">
		<a href="mailto:?Subject=The best alternatives to Amazon for buying tech right now&Body=Check%20out%20this%20article%20from%20PCWorld%3A%20https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />
		</a>
	</li>
	<li class="sosh hide cat print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>



</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=pcworld/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Mark-Hachman/" rel="author" title="Mark Hachman"><img  class="bylineImage  imgId100629551 " src="https://images.techhive.com/images/article/2015/11/headshot-crop-100629551-byline.jpg" width="34" width="34" alt="Mark Hachman" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Mark-Hachman/"><span itemprop="name">Mark Hachman</span></a></span>
						</p>
						<p class="dateline">
						
							Senior Editor, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">PCWorld</span><meta itemprop="logo" content="https://alt.idgesg.net/images/furniture/pcworld/PCW_logo_300x300.png"/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2020-04-03T13:02-0700"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
	
	
		
			<div id="articleLeaderboardWrapper">
				<div id="articleLeaderboardInner">
						
						
								
									
								




















	
		
		
		
		
			<div id="gpt-leaderboard" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboard", "true");
	    			$('#gpt-leaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboard [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
						
				</div>
			</div>
			
				
			




















	
		
		
		
		
			<div id="gpt-leaderboardmobile" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-leaderboardmobile", "true");
	    			$('#gpt-leaderboardmobile').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-leaderboardmobile [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	 
		
	
	
	
</header>




	<div class="constrain-970">
		
		
		
		
			
				<div class="lede-container">
					
					
					
						
						
							
				                
				                	
				                	
				                
				                
								
								
								
							
							
							
							
							<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
								<meta itemprop="representativeOfPage" content="1" />
								<meta itemprop="height" content="800" />
								<meta itemprop="width" content="1200" />
					    		
					    		<img data-original="https://images.idgesg.net/images/article/2020/04/14510163182_a60e2bf65a_o-100837411-large.jpg" class="lazy" loading="lazy" alt="14510163182 a60e2bf65a o" itemprop="contentUrl" itemprop="url" onload="try {performance.clearMarks('mark_primary_img_rendered'); performance.mark('mark_primary_img_rendered');}catch(e) {console.log('Error saving performance mark -- this function may not be supported in this browser');}"/>
					    		
						    		<script>
						    			try {
						    				performance.clearMarks("mark_primary_img_rendered");
											performance.mark("mark_primary_img_rendered");
						    			}
						    			catch(e) {
						    				console.log("Error saving performance mark -- this function may not be supported in this browser");
						    			}
									</script>
								
					    		<figcaption>
					    			
					    			
					    				<span class="credit" itemprop="copyrightHolder">
					    					
							    				
							    					<a href="https://www.flickr.com/photos/jeepersmedia/14510163182/in/photolist-o7dnZh-byYwhN-o7iNux-dBbKJf-fSNLTQ-dBbJdN-dBwTET-byYwF7-bMTc6P-byYwsG-bMTbNg-bMTb8g-ocnrXy-c3Yzqo-nWVbLk-o5gePQ-d6LbSG-c4tzrJ-d6Lf4W-c3YA6J-c4tPsb-owGv8z-nPQ2pK-oV4gDv-7YYMgH-oCyDnu-o71KJH-CfSXUp-9qVzTT-o7bScf-o71q76-pvShLa-48yMRq-nWV6ZA-nWV6oA-nPPM6L-4oaBTa-nd42Tu-nPQ1ir-nd3Xz5-nPPsiW-nPQwJg-nbTKYp-n9R1wo-o95XHp-o95EMa-o95FJa-o95E1R-nPPNtL-4YaiHb" target="_blank" rel="nofollow">Flickr / Mike Mozart</a>
							    				
							    				
						    				
				
							    			
							    				
							    				
							    				
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
												  	
												
							    				
							    				
												
											
									
										</span>
					    			
									
					    		</figcaption>
							</figure>
							
				
						
						
					
				</div>
			
			
		
	



<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
		<div class="techDeals">
			<div class="hed">
				<p>Today's Best Tech Deals</p>
				<p>Picked by PCWorld's Editors</p>
			</div>
			<div class="techDealsModule"></div>
		  	
			<div class="moreDeals"><a href="/deals/">Find More Hand-Picked Tech Deals</a></div>
		</div>
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
						
					
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="gpt-showcase" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("gpt-showcase", "true");
					$('#gpt-showcase').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: gpt-showcase - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
		<div class="topDeals topper">
					<div class="hed">
						<p>Top Deals On Great Products</p>
						<p>Picked by Techconnect's Editors</p>
					</div>
					<div class="topDealsModule"></div>
				  	
					<div class="moreDeals"><a href="http://www.techconnect.com/deals/">See More Hand-Picked Deals</a></div>
		</div>
	
	
	
	
	
	
</section>

</div>







<div class="constrain-970">
	
</div>




<script src="/www/js/deal-modules.js"></script>



		<section class="bodee">

			
				
				
					





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
</style>


	



	
	
	
	
		<div class="ad placement">
			
				
			





















	

		
			
			
			
				<script>
					var supLocaleEd = false;
					if (typeof countryCode !== 'undefined' && countryCode !== "" && countryCode === 'in' || (brandAbbrev === 'cio' && countryCode === 'nz')) {
						supLocaleEd = true;
					}
				</script>
				<!--  Begin inread -->
				<div id="inread" class=" ad-container">					
				</div>
				
				<script>
					if (supLocaleEd === true) {
						$("div#inread").remove();
					} else {
						consent.ads.queue.push(function(){
							IDG.GPT.addDisplayedAd("inread", "true");
							IDG.GPT.displayGoogleTagSlot('inread');
						});
					}
				</script>
				
				<!--  End inread -->	
			
			
			
			
		
	
 	
 
 
		</div>
	
	
	
	
	
	
	
	
		
			
				<div class="tocWrapper scaleArticleToc some-toc" data-tracking-category="In-article TOC">
					<legend>Table of Contents <i class="ss-navigatedown"></i></legend>
					<ul class="articleToc">
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="1"><a href="#toc-1" class="trackLink">Why you can’t find anything on Amazon</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="2"><a href="#toc-2" class="trackLink">Newegg: A good place to start</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="3"><a href="#toc-3" class="trackLink">Best Buy: Curbside pickup means quick availability</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="4"><a href="#toc-4" class="trackLink">The big boxes: Target, Walmart</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="5"><a href="#toc-5" class="trackLink">Staples, Office Depot, OfficeMax: Don’t sleep on these giants</a></li>
						
							
								
								
							
							<li data-pagenum="1" data-tocnum="6"><a href="#toc-6" class="trackLink">B&amp;H: Crystal-clear inventory and shipping data </a></li>
						
					</ul>
					<div class="toc-show-more">Show More <i class="ss-navigatedown"></i></div>
				</div>
	
					
				<script>
					var dataLayer = window.dataLayer = window.dataLayer || [];
					dataLayer.push({
						'event': 'loadInArticleToc'
						});
				</script>    
			
		
		
	
	
	
	
	
	
			
	
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
			
				<p>While Amazon has traditionally been a one-stop shop for tech gear, its mid-April delays are making other retailers viable options for getting what you want with a shorter lead time. Online stores like Newegg and B&amp;H are stepping up, alongside (gasp!) actual brick-and-mortar stores like Best Buy and Office Depot.</p><p>Alas, the old way of buying tech—looking for the absolute lowest price—is being set aside, as consumers are willing to pay a bit more for any products actually in stock. While we can’t guarantee a particular retailer will have the specific product you’re looking for, all of the ones we checked appeared to have a decent assortment of items in stock that we haven't been able to get through Amazon.</p><h2 class="toc" id="toc-1">Why you can’t find anything on Amazon</h2><p>The watchword right now isn’t so much price as availability. According to retail analyst firm NPD, <a href="https://www.npd.com/wps/portal/npd/us/blog/2020/its-time-for-home-productivity-to-shine/" rel="nofollow">productivity hardware saw “historic” sales increases</a> over the first two weeks of March, as more regions or entire states started issuing shelter-in-place orders. NPD vice president and technology analyst Stephen Baker noted that sales of computer monitors to consumers almost doubled during the first two weeks of March, versus a year ago. Mice, keyboards, and notebook PC sales increased by 10 percent.  Businesses are buying, too: Corporate notebook sales were up 30 percent in the last week of February, and then 50 percent for the first two weeks of March.</p><aside id="fsb-2074" class="fakesidebar fakesidebar-auto"><a href="https://www.pcworld.com/article/2854456/laptop-computers/the-best-pc-laptops-of-the-year.html">[ Further reading: Our picks for best PC laptops ]</a></aside><p>The buying spree has put a severe and unexpected crimp in the tech supply chain. Notebooks and monitors are still shipping from Amazon, though the company has said it’s prioritizing household goods. A survey of Amazon products PCWorld recently conducted showed a <a href="https://www.pcworld.com/article/3533341/amazon-is-delaying-most-tech-shipments-by-about-a-month-even-with-amazon-prime.html">wide swath of tech products delayed until late April</a>, and that’s still the case, generally. We <em>are</em> seeing more short-term availability of tech goods than before, though not on a par with Amazon’s typical performance. </p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/amazon-usb-c-hub-edited-100837402-orig.jpg" rel="nofollow"><img border="0" alt="amazon usb c hub edited" width="1200" height="578" data-imageid="100837402" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/amazon-usb-c-hub-edited-100837402-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Right now, even products listed as available from Amazon Prime are typically a week or so out in terms of availability.</p>
</figcaption>
</figure><h2 class="toc" id="toc-2">Newegg: A good place to start</h2><p>Newegg is making an aggressive pitch to replace Amazon as <em>the</em> one-stop shop for tech gear during the work-from-home mandates. “Newegg is very much open for business with little to no interruption,” said Anthony Chow, the global chief executive of Newegg, when asked for comment. “Sales across the board—especially tech products—are up substantially in recent weeks. In light of that, we’ve been working to secure even more inventory to keep up with the demand, much of which stems from those who need hardware and other products to work from home.”</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/newegg-deals-page-100837404-orig.jpg" rel="nofollow"><img border="0" alt="newegg deals page" width="1200" height="822" data-imageid="100837404" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/newegg-deals-page-100837404-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Newegg caters more to the hardcore enthusiast than the work-from-home crowd, but there’s still deals to be had.</p>
</figcaption>
</figure><p>Like Amazon, Newegg is a storefront for many sellers, and that’s likely why Newegg’s inventory is broader and more available right now across a variety of categories than it is at other retailers. Newegg has built in quite a bit of wiggle room, though.</p><p>Unlike Amazon, Newegg doesn’t guarantee its shipping dates. It offers only a window within which “most customers” will likely receive their products. In the example below, for instance, Newegg merely says that “most customers” will receive their webcam shipment within 6 to 16 days.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/newegg-logitect-webcam-2-100837403-orig.jpg" rel="nofollow"><img border="0" alt="newegg logitech webcam 2" width="1200" height="620" data-imageid="100837403" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/newegg-logitect-webcam-2-100837403-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Newegg seems to have good availability and reasonable prices, but this seems excessively wishy-washy, “Most” customers, in 6 to 16 days?</p>
</figcaption>
</figure><p>Once you start reading the fine print and realize the product’s shipping from Australia, the elasticity of the ship date starts to make a lot more sense. It was a similar deal with the Razer Kiyo 1080p camera with a ring light: At press time, <a class="addLink" href="http://buy.geni.us/Proxy.ashx?TSID=14154&amp;GR_URL=https%3A%2F%2Fwww.amazon.com%2Fgp%2Foffer-listing%2FB075N1BYWB%2Fref%3Ddp_olp_0%3Fie%3DUTF8%26condition%3Dall%26qid%3D1585699585%26sr%3D8-5%26ascsubtag%3DUS-001-3535569-000-000000-web-20" rel="nofollow noopener" target="_blank" data-product-name="Razer Kiyo streaming webcam" data-vars-product-name="Razer Kiyo streaming webcam" data-vars-outbound-link="https://www.amazon.com/gp/offer-listing/B075N1BYWB/ref=dp_olp_0?ie=UTF8&amp;condition=all&amp;qid=1585699585&amp;sr=8-5" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Razer" data-vars-bkmfr="Razer" data-bkvndr="Amazon" data-vars-bkvndr="Amazon">Amazon was entirely sold out</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Amazon was entirely sold out|Razer|https://www.amazon.com/gp/offer-listing/B075N1BYWB/ref=dp_olp_0?ie=UTF8&amp;condition=all&amp;qid=1585699585&amp;sr=8-5|Amazon|Razer Kiyo streaming webcam|2|Add Link">Remove non-product link</span></a>, but via Newegg, <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.newegg.com%2Fp%2FN82E16826153262&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Razer Kiyo webcam" data-vars-product-name="Razer Kiyo webcam" data-vars-outbound-link="https://www.newegg.com/p/N82E16826153262" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Razer" data-vars-bkmfr="Razer" data-bkvndr="Newegg" data-vars-bkvndr="Newegg">Razer promised delivery</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Razer promised delivery|Razer|https://www.newegg.com/p/N82E16826153262|Newegg|Razer Kiyo webcam|2|Add Link">Remove non-product link</span></a>—from Hong Kong—in as little as 4 days...or as many as 17. </p><aside class="nativo-promo nativo-promo-1 smartphone tablet desktop" id=""> </aside><p>At least Newegg’s promising you can actually <em>buy</em> tough-to-find products like webcams, which is further than you’ll get sometimes on Amazon or via other retailers like Office Depot. Newegg’s Chow said his company was well-sourced to keep up with demand.</p><p>“Our supply chain is distributed and durable, which means we’re able to source the tech products customers are looking for, and ship them on time,” Chow explained, adding that Newegg was a source for other channels, too. “In many cases,” Chow said, “brands that are having trouble selling through other distribution channels are coming to us to help them meet this growing demand, knowing that we’re able to fulfill orders as usual, even in the face of unprecedented circumstances surrounding the COVID-19 crisis.”</p><h2 class="toc" id="toc-3">Best Buy: Curbside pickup means quick availability</h2><p>Historically, the showcase for in-store technology has been Best Buy, and its physical locations continue to play a pivotal role. The company is offering either curbside pickup (instead of coming into the store) or deliveries to your home from local warehouses. </p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/best-buy-external-hard-drive-100837405-orig.jpg" rel="nofollow"><img border="0" alt="best buy external hard drive" width="1200" height="889" data-imageid="100837405" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/best-buy-external-hard-drive-100837405-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Best Buy should probably highlight its shipping options more prominently right now, but it’s doing all right in terms of stocking the tech supplies you need.</p>
</figcaption>
</figure><p>Best Buy has its strengths. If you’re willing to buy one of its <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.bestbuy.com%2Fsite%2Finsignia-usb-c-to-4k-hdmi-multiport-adapter-with-power-delivery-white%2F5577934.p%3FskuId%3D5577934&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Insignia - USB-C to 4K HDMI Multiport Adapter with Power Delivery" data-vars-product-name="Insignia - USB-C to 4K HDMI Multiport Adapter with Power Delivery" data-vars-outbound-link="https://www.bestbuy.com/site/insignia-usb-c-to-4k-hdmi-multiport-adapter-with-power-delivery-white/5577934.p?skuId=5577934" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Best Buy (Insignia)" data-vars-bkmfr="Best Buy (Insignia)" data-bkvndr="Best Buy" data-vars-bkvndr="Best Buy">Insignia brand USB-C hubs</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Insignia brand USB-C hubs|Best Buy (Insignia)|https://www.bestbuy.com/site/insignia-usb-c-to-4k-hdmi-multiport-adapter-with-power-delivery-white/5577934.p?skuId=5577934|Best Buy|Insignia - USB-C to 4K HDMI Multiport Adapter with Power Delivery|2|Add Link">Remove non-product link</span></a>, for example, that in-house brand shows more availability than name brands. Those name brands are where Best Buy suffers: Whether it’s just demand or a strain on its supply chain (or both), I found a number of products at my local Bay Area Best Buy were simply sold out. (Best Buy will sometimes append a note that the product is unavailable within a certain number of miles from your location.) </p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><p>In general, though, at press time Best Buy carried a number of USB-C hubs with immediate availability. Notebook PCs were plentiful, available either in-store or within three days if my nearby store was sold out. (Occasionally, laptops were available in another store about 10 miles away.) Best Buy listed numerous monitors, though shipping lead times were about a week. And if you need an HDMI cable—the sort of low-value necessity Amazon is forgoing right now—Best Buy seems to have plenty, such as this <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.bestbuy.com%2Fsite%2Finsignia-6-4k-ultra-hd-hdmi-cable-2-pack-black%2F5179800.p%3FskuId%3D5179800&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Insignia 6’ 4K ULtra HD HDMI cables (pack of 2)" data-vars-product-name="Insignia 6’ 4K ULtra HD HDMI cables (pack of 2)" data-vars-outbound-link="https://www.bestbuy.com/site/insignia-6-4k-ultra-hd-hdmi-cable-2-pack-black/5179800.p?skuId=5179800" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Insignia" data-vars-bkmfr="Insignia" data-bkvndr="Best Buy" data-vars-bkvndr="Best Buy">Insignia two-pack of six-foot Ultra HD HDMI cables for $40</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Insignia two-pack of six-foot Ultra HD HDMI cables for $40|Insignia|https://www.bestbuy.com/site/insignia-6-4k-ultra-hd-hdmi-cable-2-pack-black/5179800.p?skuId=5179800|Best Buy|Insignia 6’ 4K ULtra HD HDMI cables (pack of 2)|2|Add Link">Remove non-product link</span></a>, either in-store now or within a few days.</p><h2 class="toc" id="toc-4">The big boxes: Target, Walmart</h2><p>Don’t forget about Target and Walmart. Though the physical Target store’s electronics section is just a sliver of shelf area, the Target website’s <a href="https://www.target.com/c/computers-office-electronics/-/N-5xtfc" rel="nofollow">Computers &amp; Office</a> page offers an easily navigated arrangement of popular tech products. </p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/target-laptops-100837406-orig.jpg" rel="nofollow"><img border="0" alt="target laptops" width="1200" height="847" data-imageid="100837406" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/target-laptops-100837406-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Target’s own stock appears to be depleted of many items. But if it leans on Antonline, it seems bound to have it.</p>
</figcaption>
</figure><p>The estimated date of delivery isn’t among the information Target displays in its grid of products, unfortunately. Antonline handles quite a bit of Target’s fulfillment, however, and any Target listing with “antonline” as the partner seems to stand a good chance of being available. We found a surprisingly broad range of monitors available, such as a <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.target.com%2Fp%2Fdell-ultrasharp-24-monitor-black-1920-x-1200-lcd-display-8ms-response-time-in-plane-switching-panel-widescreen-16-10%2F-%2FA-78462890&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Dell UltraSharp 24-inch Monitor, Black" data-vars-product-name="Dell UltraSharp 24-inch Monitor, Black" data-vars-outbound-link="https://www.target.com/p/dell-ultrasharp-24-monitor-black-1920-x-1200-lcd-display-8ms-response-time-in-plane-switching-panel-widescreen-16-10/-/A-78462890" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Dell" data-vars-bkmfr="Dell" data-bkvndr="Target" data-vars-bkvndr="Target">Dell UltraSharp 24-inch, 1920x1200-pixel LCD on sale for $189</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Dell UltraSharp 24-inch, 1920x1200-pixel LCD on sale for $189|Dell|https://www.target.com/p/dell-ultrasharp-24-monitor-black-1920-x-1200-lcd-display-8ms-response-time-in-plane-switching-panel-widescreen-16-10/-/A-78462890|Target|Dell UltraSharp 24-inch Monitor, Black|2|Add Link">Remove non-product link</span></a>, all scheduled to arrive within 7-10 days.</p><p>Target offers a decent selection of laptops or Chromebooks (about 100), and most tended to be in stock, including solid mainstream choices like the <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.target.com%2Fp%2Fhp-pavilion-x360-14-2-in-1-laptop-intel-core-i5-8gb-ram-1tb-hdd-natural-silver-8th-gen-i5-8265u-quad-core-touchscreen-intel-uhd-graphics-620%2F-%2FA-78418356&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="HP Pavilion x360 14-inch 2-in-1" data-vars-product-name="HP Pavilion x360 14-inch 2-in-1" data-vars-outbound-link="https://www.target.com/p/hp-pavilion-x360-14-2-in-1-laptop-intel-core-i5-8gb-ram-1tb-hdd-natural-silver-8th-gen-i5-8265u-quad-core-touchscreen-intel-uhd-graphics-620/-/A-78418356" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="HP" data-vars-bkmfr="HP" data-bkvndr="Target" data-vars-bkvndr="Target">HP Pavilion x360 14-inch 2-in-1 for $745</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="HP Pavilion x360 14-inch 2-in-1|HP|https://www.target.com/p/hp-pavilion-x360-14-2-in-1-laptop-intel-core-i5-8gb-ram-1tb-hdd-natural-silver-8th-gen-i5-8265u-quad-core-touchscreen-intel-uhd-graphics-620/-/A-78418356|Target|HP Pavilion x360 14-inch 2-in-1|2|Add Link">Remove non-product link</span></a>. Target didn’t display any midrange, affordable webcams, apparently stocking only $400 to $600 models out of the range of most consumers. Cables and cords, such as a <a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.target.com%2Fp%2Fphilips-6-basic-hdmi-high-speed-cable-with-ethernet-black%2F-%2FA-53242832&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Philips 6’ Basic HDMI High Speed Cable with ethernet - Black" data-vars-product-name="Philips 6’ Basic HDMI High Speed Cable with ethernet - Black" data-vars-outbound-link="https://www.target.com/p/philips-6-basic-hdmi-high-speed-cable-with-ethernet-black/-/A-53242832" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Philips" data-vars-bkmfr="Philips" data-bkvndr="Target" data-vars-bkvndr="Target">Philips 6-foot HDMI</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Philips 6-foot HDMI|Philips|https://www.target.com/p/philips-6-basic-hdmi-high-speed-cable-with-ethernet-black/-/A-53242832|Target|Philips 6’ Basic HDMI High Speed Cable with ethernet - Black|2|Add Link">Remove non-product link</span></a>, seemed to be in stock, either available at a nearby store or shipping within a week or so.</p><p>Walmart also appears to be using its supply chain to its advantage, with either direct shipping or ship-to-store options available. Unfortunately, shipping availability isn’t highlighted on the first grid of products you’ll see, forcing you to dive into each product to check whether it’s in stock.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/walmart-netgear-routers-100837407-orig.jpg" rel="nofollow"><img border="0" alt="walmart netgear routers" width="1200" height="843" data-imageid="100837407" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/walmart-netgear-routers-100837407-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Walmart usually doesn’t clearly communicate when a product will ship in its product matrix. But it at least does note that you can swing by and pick it up in certain cases.</p>
</figcaption>
</figure><p>Fortunately, it usually is, where laptops and Chromebooks were concerned—though, oddly, some of its <a href="https://www.pcworld.com/article/3512238/motile-m142-review-ryzen-finds-a-home-in-this-surprisingly-good-budget-notebook.html">surprisingly good Motile laptops</a> didn’t have a shipping date attached. The site offered a broad selection of available USB-C hubs, such as this<a class="addLink" href="https://go.redirectingat.com/?id=111346X1569483&amp;url=https%3A%2F%2Fwww.walmart.com%2Fip%2Fethernet-HDMI-C-microSD-Readers-SD-Hub-4K-Delivery-XPS-7-in-1-Pro-60W-Adapter-MacBook-USB-Anker-Pixelbook-PowerExpand-Ports-Card-2-3-0-1Gbps-Power%2F132242767&amp;sref=https%3A%2F%2Fwww.pcworld.com%2Farticle%2F3535569%2Fthe-best-alternatives-to-amazon-for-buying-tech-right-now.html&amp;xcust=US_001_3535569_000_000000_web" rel="noopener" target="_blank" data-product-name="Anker USB C Hub Adapter" data-vars-product-name="Anker USB C Hub Adapter" data-vars-outbound-link="https://www.walmart.com/ip/ethernet-HDMI-C-microSD-Readers-SD-Hub-4K-Delivery-XPS-7-in-1-Pro-60W-Adapter-MacBook-USB-Anker-Pixelbook-PowerExpand-Ports-Card-2-3-0-1Gbps-Power/132242767" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Anker" data-vars-bkmfr="Anker" data-bkvndr="Walmart" data-vars-bkvndr="Walmart">Anker 7-in-1 USB C Hub Adapter</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="Anker 7-in-1 USB C Hub Adapter|Anker|https://www.walmart.com/ip/ethernet-HDMI-C-microSD-Readers-SD-Hub-4K-Delivery-XPS-7-in-1-Pro-60W-Adapter-MacBook-USB-Anker-Pixelbook-PowerExpand-Ports-Card-2-3-0-1Gbps-Power/132242767|Walmart|Anker USB C Hub Adapter|2|Add Link">Remove non-product link</span></a>, even though the category seemed scarce on Amazon. I found a decent monitor availability at my local store, too. Every external hard drive I checked was in stock and would ship within a week, if not sooner.</p><h2 class="toc" id="toc-5">Staples, Office Depot, OfficeMax: Don’t sleep on these giants</h2><p>Although traditional office-supply retailers carry tech necessities, most enthusiasts shop elsewhere unless they need a printer or an office chair. Adjust that attitude. Just like a bodega or rural market may hold an undiscovered trove of toilet paper, these stores may conceal a cache of tech essentials.</p><p>Remember, too, that these retailers are often offering curbside pickup: Pay ahead of time, pop the trunk, and bring some gloves. (A nice Office Depot employee put a friend’s order in the back of their trunk so they didn’t even have to to get out of the car.) Staples will ship for free with no minimum, as well as offer curbside pickup in most locations. Office Max/Office Depot (Office Depot bought OfficeMax in 2013, so they’re the same store) want you to pay at least $45 for next-day shipping.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/office-depot-officemax-availability-issues-100837408-orig.jpg" rel="nofollow"><img border="0" alt="office depot officemax availability issues" width="1200" height="831" data-imageid="100837408" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/office-depot-officemax-availability-issues-100837408-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>This is a too-common experience at Office Depot/Office Max: A product is only available in store, and it’s out of stock. Why not just tell customers and save them the frustration?</p>
</figcaption>
</figure><p>Office Depot/Office Max has a big kink to work out of their database, though: What they promise on the product page isn’t backed up by their inventory. Take a Dell Inspiron l found. Oh, store pickup is available? And I can get it today? Nope. Click through to the product page, and Office Depot pulls a bait-and-switch: The Inspiron is only available for in-store pickup...but it’s not available for pickup within 100 miles. </p><p>In other examples, I found a few “in-store” pickups that would require a 20-minute drive to purchase, especially in laptops. The general inventory of home-office tech like external hard drives, mice, keyboards was abundant. Monitors, though, seemed to be non-existent, at least among the five options I chose. Printers and especially ink were in stock.</p><p>(Be aware that Office Max/Office Depot and Staples also sell paper and cleaning products, similar to the cleaning aisles in your grocery store. Yes, they sell toilet paper; my local stores were completely sold out, but maybe you’ll have better luck.)</p><p>You won’t waste quite as much time buying at Staples. Staples does tell you clearly whether a product is in stock, though it makes you click the “1-Hour pick-up” button before it checks inventory. If Staples then makes you check other stores, it returns only locations where the item is available. Office Depot/OfficeMax make you scroll through store after store, even if none have the item in stock.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/staples-monitor-stock-100837409-orig.jpg" rel="nofollow"><img border="0" alt="staples monitor stock" width="1200" height="817" data-imageid="100837409" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/staples-monitor-stock-100837409-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>Staples isn’t perfect, as it too sometimes leads you to believe a product is in stock, and then forces you to check elsewhere. It does make the process simpler than some of the competition, though.</p>
</figcaption>
</figure><p>Staples currently delivers for free, with no minimum charge. Unfortunately, there’s often a disclaimer that accompanies the standard “delivered FREE in 3-5 business days:” “Due to high demand, delivery may take longer than expected.” How long? Staples doesn’t tell you, at least not on the product page.</p><p>I saw decent availability of notebook PCs for delivery (in about 3-4 days) and in-store pickup. Monitors were somewhat difficult to find, though available. Staples offered one-day delivery of computer mice and keyboards, even an <a class="addLink" href="https://www.qksrv.net/links/8200811/type/am/sid/US-001-3535569-000-000000-web-20/https://www.staples.com/fellowes-slimline-antimicrobial-protection-wireless-keyboard-and-mouse-combo-black-9893601/product_303214" rel="nofollow noopener" target="_blank" data-product-name="Fellowes Slimline Antimicrobial Protection Wireless Keyboard and Mouse Combo" data-vars-product-name="Fellowes Slimline Antimicrobial Protection Wireless Keyboard and Mouse Combo" data-vars-outbound-link="https://www.staples.com/fellowes-slimline-antimicrobial-protection-wireless-keyboard-and-mouse-combo-black-9893601/product_303214" data-product-id="000000" data-vars-product-id="000000" data-bkmfr="Fellowes" data-vars-bkmfr="Fellowes" data-bkvndr="Staples" data-vars-bkvndr="Staples">antimicrobial mouse-and-keyboard combo</a><a class="removelink" href="#" rel="nofollow"><span class="removelink-tooltip" style="display: none;" data-removeparamvalues="antimicrobial mouse-and-keyboard combo|Fellowes|https://www.staples.com/fellowes-slimline-antimicrobial-protection-wireless-keyboard-and-mouse-combo-black-9893601/product_303214|Staples|Fellowes Slimline Antimicrobial Protection Wireless Keyboard and Mouse Combo|2|Add Link">Remove non-product link</span></a> I would have sworn would be out of stock. One-day delivery was typical for external hard drives. USB-C hubs seemed to require about a week for shipping, through they were available.</p><h2 class="toc" id="toc-6">B&amp;H: Crystal-clear inventory and shipping data </h2><p>We routinely feature consumer electronics retailer B&amp;H in our daily deals, but the company (which is privately held and has one store in New York City, along with a bustling online store) probably doesn’t have the name recognition it deserves. It's worth checking out, especially in these times of scarcity, as the company seems to have a good handle on its inventory and delivery data. </p><p>You’ll find ship dates clearly listed, with clear communication of when the product will ship and when you can expect it—well, except for the featured products at the top of the page. We found a decent amount of inventory across a number of different product lines, and “request stock alert” notifications that you could sign up for. And if you’ve become numbed by scrolling through lists of “sold out” notifications (looking at you, Best Buy) B&amp;H is one of the retailers that seems to prioritize showing what it <em>does</em> have, versus what it doesn’t.</p><figure class="large "><a class="zoom" href="https://images.idgesg.net/images/article/2020/04/bh-usb-c-hub-100837410-orig.jpg" rel="nofollow"><img border="0" alt="bh usb c hub" width="1200" height="976" data-imageid="100837410" data-license="IDG" data-original="https://images.idgesg.net/images/article/2020/04/bh-usb-c-hub-100837410-large.jpg" class="lazy" loading="lazy"/></a> <small class="credit">Mark Hachman / IDG</small>
<figcaption>
<p>After shopping elsewhere, you’ll appreciate B&amp;H’s clear statements of when to expect your products, as well as the fairly ample inventory.</p>
</figcaption>
</figure>
			
		
		
	
		
		
			
		
		
		
		
		
	</div>
	
		<script>
			try {
				performance.mark("mark_article_body_rendered");
			}
			catch(e) {
				console.log("Error saving performance mark -- this function may not be supported in this browser");
			}
		</script>
	
	
	
		
		
		
	
	
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/computers"><span class="primary-cat-name2">PCs</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/laptop-computers"><span class="primary-cat-name2">Laptops</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/amazon-com"><span class="primary-cat-name2">Amazon.com</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/consumer-electronics"><span class="primary-cat-name2">Consumer Electronics</span></a></li>
			 
			
				
				
					 
						 
				    				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
	
		
		
	

















	
	<section class="pagination">
		
	    
		    <span class="page-numbers">
			    
			    	<a href="/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html" class="page-link current">1</a>
			    
			    	<a href="/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html?page=2" class="page-link ">2</a>
			    
		    </span>
		    <span class="current-page">
		    	Page 1
		    </span>
		
		
			<a href="/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html?page=2" class="page-link next" rel="next">Next <i class="ss-icon ss-navigateright"></i></a>
		
	</section>
	
	
	<div class="mobile-page-nav">
		
			
				
				<div id="article-top-page-number">Page 1 of 2</div>
				
					<a href="/article/3535569/the-best-alternatives-to-amazon-for-buying-tech-right-now.html?page=2" class="page-link next" rel="next"><i class="ss-icon ss-navigateright"></i></a>
				
			
		
			
		
	</div>


	 
	




<script>
$("body").on('click', 'a[data-product-id]', function() {
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
	window.permutive.track('AffiliateLinkClick', {
	    category: $(this).attr("data-bkc"),
	    name: prodName,
	    manufacturer: $(this).attr("data-bkmfr"),
	    vendor: $(this).attr("data-bkvndr")
	});
	
});
</script>


	<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com/|csoonline.com/|computerworld.com/|itnews.com/|itworld.com/|infoworld.com/|networkworld.com/|javaworld.com/|techconnect.com/|techhive.com/|macworld.com/|pcworld.com/|greenbot.com/|gamestar.com/|idginsiderpro.com/|idgesg.net/", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>


<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	

	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





<script src="/www/js/video/embedder-jwp.js?v=20200402114305"></script>

<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>

















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
		

	
	













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 350px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 350px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 350px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 350px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 350px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 350px;
	}
}
</style>

<script type="text/javascript">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</script>		



<script>
// this debouce() function is used here and with related-content ribbon-ribbon.jsp
function debounce(func, wait, immediate){
    var timeout;
    return function(){
        var context = this, args = arguments;
        var later = function(){
            timeout = null;
            if (!immediate) func.apply(context, args);
        };
        var callNow = immediate && !timeout;
        clearTimeout(timeout);
        timeout = setTimeout(later, wait);
        if (callNow) func.apply(context, args);
    };
}

let galleryNode; // undefined if element is not found
let mobileDeviceWidth = 0;
let eventDeviceOrientation = "portrait";

if (window.innerWidth > 0) {
	mobileDeviceWidth = window.innerWidth;
} else {
	mobileDeviceWidth = document.documentElement.clientWidth;
}

if ($("figure").hasClass("thm-gallery")) {
	galleryNode = document.querySelector('.thm-gallery .embed-wrapper');
}

var supportsOrientationChange = "onorientationchange" in window,
orientationEvent = supportsOrientationChange ? "orientationchange" : "resize";

window.addEventListener(orientationEvent, function() {
	  // if device is rotated to landscape orientation
	  if (window.orientation === 90 || window.orientation === -90) {
		  eventDeviceOrientation = "landscape";
	  } else {
		  eventDeviceOrientation = "portrait";
	  }
}, false);

if (typeof galleryNode !== 'undefined') {	
	if (mobileDeviceWidth <= 480) {
		window.addEventListener('scroll', debounce(function(e) {
			// if device is rotated to landscape after page load, do not pause and play video!
			if (eventDeviceOrientation !== "landscape") {
				if (isVisible(galleryNode)) {
					jwplayer('bcplayer-gallery').play();
				} else {
			    	jwplayer('bcplayer-gallery').pause();
			  	}
			}			
		}, 5));
	}
}
</script>


					










				
			
		
		</section><!-- /.bodee -->

		














		
			
				











<script>var suppressEd = false;</script>







	<div id="content-recommender">
		<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="PCWorld_1"></div>  
	</div>
	<script>
		var obEdition = edition ||  countryCode || '';
		var widgetId="";
		
		if (obEdition === "asean") {
			widgetId="AR_3";
			if ($("body").hasClass("slideshow")) {
				widgetId="AR_4";
			}
		}
		if (widgetId !== "") {
			$(".OUTBRAIN").attr("data-widget-id", widgetId);
		}
		
		(function() {
			// suppressed for certain editions
			if (!suppressEd) {
				let obScript = document.createElement('script');
				obScript.src = '//widgets.outbrain.com/outbrain.js';
				document.body.appendChild(obScript);
			}
		})();
	</script>


			
				
		
	
		<div id="amazon-bottom-widget">
			<div class="amzn-custom-header">Shop Tech Products at Amazon</div>
			<div id="amazon-links" class="rr sector" original="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&storeId=httpwwwidgcsm-20&adInstanceId=54ab7a69-a67d-4f7f-8f8c-cef18fa3f42f">
				<code type="text/javascript"><!--
				           console.log('lazyloaded amazon widget links in footer');
				           //-->
				</code>
			</div>
		</div>
		<script>
		$(window).load(function() {
			consent.adsel.queue.push(function(){
				try {
					$("div#amazon-links").lazyLoadAd({
				          threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
				          forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
				          onLoad       : false,       // Callback function on call ad loading
				          onComplete   : false,       // Callback function when load is loaded
				          timeout      : 2000,        // Timeout ad load
				          debug        : false,       // For debug use : draw colors border depends on load status
				          xray         : false      // For debug use : display a complete page view with ad placements
				    });
				} catch (exception){
					console.log("ERROR loading amazon widget links " + exception);
				}
			});
		});
		</script>
	


	<div class="coupons">
		<h3>Coupon Codes</h3>
		<ul class="coupons__list">
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/dell">
						<h4 class="coupon_title">Dell Small Business Coupon Code</h4>
						<h5 class="coupon-desc">Buy PC and save 10% on accessories with coupon</h5>
					</a>
				</li>
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/hotwire">
						<h4 class="coupon_title">Hotwire Promo Code</h4>
						<h5 class="coupon-desc">Register to get a $10 Hotwire coupon code</h5>
					</a>
				</li>
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/hp">
						<h4 class="coupon_title">Hp Coupon Code</h4>
						<h5 class="coupon-desc">Extra 8% on $899+ laptops: HP coupon</h5>
					</a>
				</li>
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/expedia">
						<h4 class="coupon_title">Expedia Coupon</h4>
						<h5 class="coupon-desc">Extra 15% off activity bookings with Expedia coupon code</h5>
					</a>
				</li>
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/hotels-com">
						<h4 class="coupon_title">Hotels Com Coupon</h4>
						<h5 class="coupon-desc">Stay Later: 40% + extra 10% off  refundable bookings with Hotels.com promo code</h5>
					</a>
				</li>
			
				<li class="coupon">
					<a class="coupon__link" href="https://www.pcworld.com/couponcodes/samsung">
						<h4 class="coupon_title">Samsung Promo Code</h4>
						<h5 class="coupon-desc">20% off when you bundle accessories - Samsung offer</h5>
					</a>
				</li>
			
		</ul>
	</div>


	<div class="lazyload_ad">
		<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
		</code>
	</div>



		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		













<div id="panel-loader"></div>
<!-- IDGMPM-11812, category.getCategoryType() returns an integer, and 9 stands for tentpole-->
 



	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20200402114305" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,10);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Sponsored Links</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0) {
						html += selectedAds[i].pixel;
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	




		










<link rel="stylesheet" href="/www.idgcsmb/css/footer.css?v=20200402114305" />
<link rel="stylesheet" href="/www.idgcsmb.pcw/css/footer.css?v=20200402114305" />
<div id="network"></div>

	












<footer id="footer" class="clearfix">
    <div class="container clearfix">
    	<div class="footer-col">
    		<a href="http://pcworld.com" id="footer-logo-pcw" class="ir">PCWorld</a>
    		<p>PCWorld helps you navigate the PC ecosystem to find the products you want and the advice you need to get the job done.</p>
    		<ul>
    			<li><a href="/about/about.html">About Us</a></li>
				<li><a href="/about/contact.html">Contact Us</a></li>
				<li><a href="/faq" rel="nofollow">Digital Magazine</a></li>
				<li><a href="https://simplecirc.com/give_a_gift/pcworld">Gift Subscription</a></li>
				<li><a href="https://www.idg.com/about-adchoices-pcworld/" rel="nofollow">Ad Choices</a></li>
				<li><a href="/about/member-preferences.html">Member Preferences</a></li>
				<li><a href="/about/cookie-policy.html">Cookie Policy</a></li>
				<li><a href="/newsletters/signup.html">Newsletters</a></li>
				<li><a href="https://www.idg.com/terms-of-service-agreement/" rel="nofollow">Terms of Service Agreement</a></li>
				<li><a href="/index.rss">RSS</a></li>
				<li><a href="/about/privacy.html" rel="nofollow">Privacy Policy</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://shop.pcworld.com">Shop</a></li>
				<li><a href="/about/affiliates.html">E-commerce Affiliate Relationships</a></li>
				<li><a href="/about/ccpa.html">California: Do Not Sell My Personal Info</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<h2>PCWorld Categories</h2>
    		<ul>
    			<li><a href="/category/business/">Business</a></li>
				
				<li><a href="/category/laptop-computers/">Laptops</a></li>
				<li><a href="/category/mobile/">Mobile</a></li>
				<li><a href="/category/computers-all/">PC Hardware</a></li>
				
				<li><a href="/deals">Deals</a></li>
			</ul>
			<ul class="right">
				<li><a href="/category/printers/">Printers</a></li>
				<li><a href="/category/security/">Security</a></li>
				<li><a href="/category/software/">Software</a></li>
				<li><a href="/video/">Videos</a></li>
				<li><a href="/category/windows/">Windows</a></li>
			</ul>

			<h3>IDG Network Sites</h3>
			<ul>
				<li><a href="https://www.idg.com/advertise-with-us/pcworld/" rel="nofollow">Advertise</a></li>
				<li><a href="https://www.idg.com/technetwork/technetwork-permissions-guildelines/" rel="nofollow">Permissions</a></li>
				<li><a href="http://www.macworld.com/" rel="nofollow">Macworld</a></li>
				<li><a href="http://www.techadvisor.co.uk/">Tech Advisor</a></li>
				<li><a href="http://www.techhive.com/" rel="nofollow">TechHive</a></li>
			</ul>
			<ul class="right">
				<li><a href="https://www.idg.com/technetwork/" rel="nofollow">IDG TechNetwork</a></li>
				<li><a href="https://www.idg.com/" rel="nofollow">IDG</a></li>
				<li><a href="http://blog.idg.com/" rel="nofollow">IDG Blog</a></li>
				<li><a href="https://www.idg.com/work-here/" rel="nofollow">Careers at IDG</a></li>
			</ul>
    	</div>
    	<div class="footer-col">
    		<div id="footer-subscribe" class="clearfix">
	    		<a href="https://simplecirc.com/subscribe/pcworld">
	    			<img src="//alt.idgesg.net/images/furniture/pcworld/footer-subscribe-mag-pcw.png" alt="PCWorld Magazine Cover">
	    			<h2>Get PCWorld's Digital Editions</h2>
	    			<span class="btn-link">Subscribe Now</span>
	    		</a>
    		</div>
    		<div id="footer-social">
    			<span>Follow us</span> <a href="http://www.facebook.com/PCWorld" class="network-fb ss-icon ss-social-circle banner-social banner-fb" alt="Facebook" itemprop="sameAs" rel="nofollow">
						&#xF610;
					</a>
					<a href="https://twitter.com/pcworld" class="network-tw ss-icon ss-social-circle banner-social banner-tw" alt="Twitter" itemprop="sameAs" rel="nofollow">
						&#xF611;
					</a>
					
						<a href="https://www.youtube.com/user/PCWorldVideos" class="network-youtube ss-icon ss-social-circle banner-social banner-youtube" alt="YouTube">
							&#xF630;
						</a>
					 			    			
    		</div>
    		
    		 <p>Visit other IDG sites:</p>
    		
    		<div id="idgInfo" class="styled-select">		
		            <select onchange="location = this.options[this.selectedIndex].value;" id="jumpMenu" name="jumpMenu" d30tagged="1" style="visibility: visible;">
		                <option value="">Select One</option>
		                
		                	
		                













	
		<option value="https://www.greenbot.com">Greenbot</option>
	
		<option value="https://www.macworld.com">Macworld</option>
	
		<option value="https://www.pcworld.com">PCWorld</option>
	
		<option value="https://www.techconnect.com">TechConnect</option>
	
		<option value="https://www.techhive.com">TechHive</option>
	

		            </select>
		    </div>
		    
		    <div class="copyright">
		    	<img src="https://alt.idgesg.net/images/logos/logo-footer-white.png" alt="IDG Communications" />
				<p><small><a href="http://idgcsmb.com/terms-of-service-agreement/">Copyright</a> &copy; 2020 IDG Communications, Inc.</small></p>		    
			</div>
    	</div>
    </div> 
</footer>

	 
 	<script src="/www/js/ads/stickyLb.js"></script>
	<script>
		(function(){
			var parallaxArgs = {
				topNavEl: 'main-nav',
				topNavIsSticky: false,
				leaderboadrdId: 'gpt-leaderboard', 
				adContainer: 'articleLeaderboardWrapper',
				adUnit: 'articleLeaderboardInner',
				viewabilityTime: 7000
			}
			parallaxLb(parallaxArgs) ;
		})();
		
	</script>



		
				
		
			
				
			




















	
		
		
		
		
			<div id="gpt-infunnel" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt-infunnel", "true");
	    			$('#gpt-infunnel').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt-infunnel [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
		
		
			
		
















<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script> 

<script src="/www.idgcsmb/js/jquery/jquery-ui-tools.js"></script>


	<script>
		$(document).ready(function() {
			if (typeof $.cookie("geoPromoDontShow") === 'undefined' && typeof $.cookie("geoPromoSeen") === 'undefined' && navigator.languages.indexOf("es") > -1 && $thm.deviceWidthAtLeast($thm.deviceBreakpoints.wide)) {
				$.get("/napi/tile?def=international.promo", 
					function(data) {
						$("body").prepend(data);
						var visitTime = new Date();
						visitTime.setTime(visitTime.getTime()+1000*60*60*24); //24 hours
				      	$.cookie('geoPromoSeen', 'true', { expires: visitTime, path: '/' });
						$(".geo-promo .ss-delete, a.cont-here, a.dont-show").click(function(e) {
							e.preventDefault();
							if ($(this).is(".dont-show")) {
								visitTime.setTime(visitTime.getTime()+1000*60*60*24*30); //30 days
						      	$.cookie('geoPromoDontShow', 'true', { expires: visitTime, path: '/' });
							}
							$(".geo-promo").fadeOut(function() {$(".geo-promo").remove()})
						});
					}
				);
			}
		});
	</script>

<script src="/www.idgcsmb/js/thm_post.js?v=20200402114305"></script>
<script src="/www/js/product-toc.js?v=20200402114305"></script>
<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.md5.js"></script>

	<script src="/www.idgcsmb/js/jquery/plug-ins/jquery.colorbox-min.js"></script>


<script src="/www.idgcsmb/js/autocomplete.js"></script>







<script>
$(function() {
	if (typeof $.fn.lazyload === 'undefined' ) {
		if ('loading' in HTMLImageElement.prototype) {
		    const images = document.querySelectorAll('img[loading="lazy"]');
		    images.forEach(img => {
		      img.src = img.dataset.original;
		    });
		}
		else {
			$.getScript('/www/js/jquery/jquery.lazyload.min.js',function(){
				 $("img.lazy").lazyload({ 
			    	effect : "fadeIn", 
			    	threshold: 200,
			    	failure_limit:25
				 });
			});
		}
	}
});
</script>

<!-- Do not include here when empty article or not empty and article is slideshow as this script is included with DRR code in body-base.jsp. -->
















<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>

<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
try {
	$("div.lazyload_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
	}) ;
}
catch (exception) {
	console.log("Error with lazyLoadAd: "+exception);
}
</script>

<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
<script>
$(document).ready(function() {
	$("table.tablesorter").tablesorter({
		widgets: ['zebra']
	});
	
	$("table.tablesorter tbody tr").hover(function() {
		$(this).toggleClass("selected");
	});
	
	$("table.tablesorter thead tr th").each(function(){			
		if ($(this).find('.ss-icon').length < 1) {
			$(this).append('<i class="ss-icon"></i>');
		}
	});
	
});
</script>

<script>
	//click event for BrandPost "Learn More" buttons
	$(".learn-more").click(function(event) {
		 var brandpost_txt = "<div class=\"about-brandposts\"><p>BrandPosts are written and edited by members of our sponsor community. BrandPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of BrandPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 brandpost_txt = "<div class=\"about-brandposts\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(brandpost_txt);
		 $(".about-brandposts").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-brandposts").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-brandposts .close-bar").click(function() {
			 $(".about-brandposts").remove();
			 return false;
		 });
		 return false;
	});
</script>

<script>
//click event for Sponsorship "Learn More" buttons
	 $(".learn-more-sponsorship").click(function(event) {
		 var sponsorship_txt = "<div class=\"about-sponsorships\"><p>This content is written and edited by members of our sponsor community. Such sponsor content creates an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of sponsor content.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 if ($(".blog-byline.sponsored-post").length > 0) { //for Nativo sponsoredPosts
			 sponsorship_txt = "<div class=\"about-sponsorships\"><p>SponsoredPosts are written and edited by members of our sponsor community. SponsoredPosts create an opportunity for an individual sponsor to provide insight and commentary from their point-of-view directly to our audience. The editorial team does not participate in the writing or editing of SponsoredPosts.</p><hr/><a class=\"close-bar\" href=\"#\">Close</i></a></div>";
		 }
		 $("body").append(sponsorship_txt);
		 $(".about-sponsorships").css("top",event.pageY);
		 if ($("body").width() >= 955) { // need different behavior at desktop breakpoint and above
			 //find difference between X position clicked and body width and set as right attr 
			 //this is so tooltip doesn't overflow window
			 var xpos = $("body").width() - event.pageX;
			 $(".about-sponsorships").css({"right":xpos,"margin-right":"0"});
		 }
		 $(".about-sponsorships .close-bar").click(function() {
			 $(".about-sponsorships").remove();
			 return false;
		 });
		 return false;
	 });
</script>




	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->


<script type='text/javascript'>

	
	$(document).ready(function(){

		$('#extra-nav-toggle a').click(function(){
			if($(this).hasClass('open')){
				$('#extra-nav').hide();
				$(this).removeClass('open');
				$('#extra-nav-toggle a').removeClass('ss-delete');
				$('#extra-nav-toggle a').addClass('ss-dropdown');		
			} else {
				$('#extra-nav').show();
				$(this).addClass('open');
				$('#extra-nav-toggle a').removeClass('ss-dropdown');
				$('#extra-nav-toggle a').addClass('ss-delete');					
			}
			return false;
		});
		
		var isMobile = window.matchMedia("only screen and (min-width: 60.625em)");
			
			if (!isMobile.matches) {
				$("#dealsNav span").removeClass("ss-dropdown").addClass("ss-directright");
				$("a.couponCodeMob span.rightArrow").remove();
				$("a.couponCodeMob").append('<span class="mobCoupons ss-directright"></span>');
				$('#dealsNav').click(function() {
					if ($("#dealsNav span").hasClass("ss-directright")) {
						$("#dealsNav span").removeClass("ss-directright").addClass("ss-dropdown");
						$(".dealsList").css({ 'display':'block'});
					}
					else {
						$("#dealsNav span").removeClass("ss-dropdown").addClass("ss-directright");
			    		$(".dealsList").css({ 'display':'none'});
					}
				});
				$("a.couponCodeMob").click(function() {
					if ($(".couponCodeMob .mobCoupons").hasClass("ss-directright")) {
						$(".couponCodeMob .mobCoupons").removeClass("ss-directright").addClass("ss-dropdown");
						$(".couponChildLinks").css({ 'display':'table'});
					}else {
						$(".couponCodeMob .mobCoupons").removeClass("ss-dropdown").addClass("ss-directright");
						$(".couponChildLinks").css({ 'display':'none'});
					}
				
				});   
			}
			else {
				$('li.dealsNav').mouseenter(function() {
			    	$(".dealsList").css({ 'display':'block'});
				});           
		
				$('ul.dealsList').mouseleave(function() {  
				    $(".dealsList,.couponChildLinks").css({ 'display':'none'});	    
				});
				
				$('li.couponCodes').mouseenter(function() {
				    $(".couponChildLinks").css({ 'display':'block'});
				});           
			
				$('ul.couponChildLinks').mouseleave(function() {  
				    $(".couponChildLinks").css({ 'display':'none'});	    
				});
			}

    	<!-- if (isMobile.matches) {	 -->
    		
			
		
		<!-- } -->
		  				  
	});//-- end document Ready
		
	


					$(document).ready(function() {
						var tocTopper = 10;
						if ( $('body').hasClass('macworld') || $('body').hasClass('pcworld') || $('body').hasClass('techhive')) {
							tocTopper = 0;
						}
						
						$(window).resize(function() { 
							var scaleTocFixBegin = $("#drr-container.cat").offset().top - tocTopper;
							var scaleTocFixEnd = $(".bodee").offset().top + $(".bodee").height();			
							var scaleTocStartOffsetTop = 5;
							doProductToc(true,false,scaleTocFixBegin,scaleTocFixEnd,scaleTocStartOffsetTop);
	
						}).resize();
					});
				

	g_bRequireHttps = true;
	 	var localeId = getLocale();
		$.ajax('/ads/tso?localeId=' + localeId,{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>

		
	<script type="text/javascript">
		var subscribersSiteId = "fad3adbe-1461-402a-a80d-b32e46abd3fb"; 
	</script>
	<script type="text/javascript" src="https://cdn.subscribers.com/assets/subscribers.js"></script>


		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>	

 		














	
	
	    
	    
		   	
		   	
		   	
	    
    	
    	
	    
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	




 		
		










<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"pcw","e":"view","t":"article","id":"3535569"});
});
</script>
	
	
		<div id="loginModal"></div>
		<div id="logoffModal"></div>
		<div id="abuseModal"></div>

		
			<!-- rev: 20200402114305  -->
		
		
		
		
			
				
			




















	
		
			<div id="gpt-skin" class=" ad-container"></div>
    			<script type="text/javascript">
    			consent.ads.queue.push(function(){
    				try {
	    				IDG.GPT.addDisplayedAd("gpt-skin", "true");
	    				IDG.GPT.displayGoogleTagSlot('gpt-skin');
	    			}
	    			catch (exception) {
	    				console.log("Error with IDG.GPT: " + exception);
	    			}
    			});
    			</script>
		
		
		
		
	
 
 
			
		
		
		
			
		




















	
		
		
		
		
			<div id="gpt_custom_promo_2" class=" ad-container"></div>
    		<script type="text/javascript">
    		consent.ads.queue.push(function(){	
    			try {
	    			IDG.GPT.addDisplayedAd("gpt_custom_promo_2", "true");
	    			$('#gpt_custom_promo_2').responsiveAd({screenSize:'971 1115', scriptTags: []});
	    			IDG.GPT.log("Creating ad: gpt_custom_promo_2 [971 1115]");
	    		}
				catch (exception) {
					console.log("Error with IDG.GPT: " + exception);
				}
    		});
    		</script>
    	
	
 
 
	
			
	</body>
</html>
